If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

fix the setTimeout() hack in charsetDetectorsOverlay.js

VERIFIED FIXED in M14

Status

()

Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: cata)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] ETA: 14/Feb - Work done, ready for checkin)

ftang, according to waterson, you don't need to do this in
charsetDetectorsOverlay.js:

/* this is really hacky, but waterson say it will work */
setTimeout("LoadDetectorsMenu()", 10000);

waterson, can you explain to ftang what he needs to do?

Comment 1

18 years ago
The "Right Way" (quotes like Dr. Evil) is to use something like:

document.addEventListener('load', MyOnloadHandler, false);

(cc hyatt and joki -- I looked at DOM Level 2 spec and it's different from our
current APIs; obviously, using our current APIs is the only way to make this
work right now.)

This effectively adds an 'onload' handler to your document.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Comment 2

18 years ago
Mark M11.

Comment 3

18 years ago
How is the DOM spec different from our stuff?  We do support multiple way to do
this internally but among them is the DOM compliant one that you gave an
example of.

Comment 4

18 years ago
Never mind. I was looking at a DOM L2 spec dated March 4, 1999.

Comment 5

18 years ago
I try what waterson put down but it does not work. I may make some stupid mistake there. No time to work on this . Move to M12

Updated

18 years ago
Target Milestone: M11 → M12

Comment 6

18 years ago
reassign Charset Auto Detect menu bugs to cata per bobj/ftang chat.

Updated

18 years ago
Target Milestone: M13 → M14

Comment 7

18 years ago
Out of time for M13, moving to M14.

Comment 8

18 years ago
change OS to ALL
Hardware: PC → All

Updated

18 years ago
Keywords: beta1

Comment 9

18 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]

Comment 10

18 years ago
On 1999-10-15 13:58, ftang said he tried waterson's suggestion, but it did
not work.  But there have been no further comments.  Can someone (ftang or
waterson) offer some enlightenment or details?

Comment 11

18 years ago
cata told me he will change the mecanism for auto detector menu to the mechanism
he used for charset menu, in that case, this code will simply go away when he
change that.
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+] → [PDT+] ETA: 14/Feb
(Assignee)

Comment 12

18 years ago
Frank's right.
(Assignee)

Comment 13

18 years ago
Frank is right.
Whiteboard: [PDT+] ETA: 14/Feb → [PDT+] ETA: 14/Feb - Work done, ready for checkin
(Assignee)

Comment 14

18 years ago
Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 15

18 years ago
*** Bug 27950 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
I verified this in 2000022108 Win32, Mac, and Linux build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.