Closed Bug 1521670 Opened 2 years ago Closed 2 years ago

Use a common naming scheme for the app update browser tests

Categories

(Toolkit :: Application Update, enhancement)

59 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

References

Details

Attachments

(1 file)

When the tests for the About Dialog were created in bug 599233 a naming scheme for the test files was used to make it easier to know what the test actually tests. The existing tests should be renamed so they also use this naming scheme.

About Dialog tests start with
browser_about

Doorhanger tests would start with
browser_doorhanger

Options page tests would start with
browser_options

From bug 599233 comment #6

fc = foreground check
bc = background check
sp = startup processing
check = only the update check was performed (also keeps these tests sorted together)
downloadAuto = an update download was performed automatically (app.update.auto = true)
downloadOptIn = the client chose to download an update (app.update.auto = false)
downloaded = an update was already downloaded automatically (app.update.auto = true)
patch = patch condition tests (also keeps these tests sorted together)

I decided to hold off on the renaming of browser_TelemetryUpdatePing.js and browser_updateAutoPrefUI.js. I'll do these when adding the options page tests.

Attachment #9038165 - Flags: review?(mhowell)
Attachment #9038165 - Flags: review?(mhowell) → review+
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b9d2e3ae5a3b
Use a common naming scheme for the app update browser tests. r=mhowell
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.