Open Bug 1521712 Opened 9 months ago Updated Last month

Clicking on a scrollbar area with the element picker should select the element this scrollbar belongs to

Categories

(DevTools :: Inspector, enhancement, P3)

enhancement

Tracking

(Not tracked)

People

(Reporter: pbro, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Today you can't click on scrollbars to select elements in the inspector. Doing so doesn't select anything and keeps the picker engaged.
The idea would be for this to actually select the element the scrollbar belongs to, and disengage the picker.

This would help a lot with investigating overflow issues. Sometimes you're not sure which element in the DOM has the overflow (i.e. the scrollbar), as there may be many similar-size elements nested.

Severity: normal → enhancement
Priority: -- → P3
See Also: → 1521776
Assignee: nobody → pbrosset
Status: NEW → ASSIGNED
Pushed by pbrosset@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7f6996c8b32f
Pick on mouseup to allow picking scrollbars; r=rcaliman
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Backout by opoprus@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/5e7f43df5048
Backed out changeset 7f6996c8b32f for breaking firefox when devtools is opened a=backout
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 66 → ---
Blocks: 1529280
Duplicate of this bug: 1312146

I had attempted an earlier fix in bug 1312146, in attachment 9029936 [details] [diff] [review].

Unassigning me from this bug for the moment. We'll likely pick this up again in Q2 2019, but it might not be me.

Assignee: pbrosset → nobody
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.