Show scrollable elements in the markup-view using markup-badges

RESOLVED FIXED in Firefox 66

Status

P3
enhancement
RESOLVED FIXED
a month ago
a day ago

People

(Reporter: pbro, Assigned: pbro)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 66
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a month ago

Debugging unwanted scrollbars in a web page often starts with identifying what element is having the scrollbar.
This is sometimes more difficult than it seems as many elements may be nested into each other, sharing the same size.

The idea of this feature is to make use of the markup-badges we already use for flexbox, grid, or events, by adding one for scrollable elements.

(Assignee)

Updated

a month ago
Assignee: nobody → pbrosset
Status: NEW → ASSIGNED
(Assignee)

Comment 1

a month ago

Created attachment 9038245 [details]
Bug 1521776 - Add new scrollable markup badges; r?gl

Detect when nodes are scrollable on the actor side, and use this
information to display new [scrollable] markup-badges in the inspector.
Also track this dynimically so badges are added/removed when necessary.
Hide this behind a pref for now, until this gets tested by users and
validated.

Comment 3

29 days ago
Pushed by pbrosset@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/21cb7caef246
Add new scrollable markup badges; r=gl

Comment 4

29 days ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 29 days ago
status-firefox66: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
(Assignee)

Updated

23 days ago
Blocks: 1523543
(Assignee)

Updated

a day ago
Blocks: 1529280
(Assignee)

Updated

a day ago
Duplicate of this bug: 1342028
You need to log in before you can comment on or make changes to this bug.