Closed Bug 1521826 Opened 9 months ago Closed 9 months ago

Handle extensions with lots of shortcuts in manage shortcuts

Categories

(WebExtensions :: Frontend, enhancement, P2)

enhancement

Tracking

(firefox66 wontfix, firefox67 verified)

VERIFIED FIXED
mozilla67
Tracking Status
firefox66 --- wontfix
firefox67 --- verified

People

(Reporter: mstriemer, Assigned: mstriemer)

References

(Depends on 1 open bug)

Details

Attachments

(3 files)

Some extensions have lots of shortcuts, there could just be a lot of options (like Tree Style Tab [1]) or a lot of empty commands to be redefined dynamically in the extension (like Flagfox [2]).

We should come up with a way to handle these cases. Likely candidates are limiting the number of commands shown with an option to expand, or hiding commands without a description or shortcut (or both).

[1] https://addons.mozilla.org/en-US/firefox/addon/tree-style-tab/
[2] https://addons.mozilla.org/en-US/firefox/addon/flagfox/

Duplicate of this bug: 1521389
Blocks: 1303384

The plan is to do two things: Move the commands that have shortcuts to the top of the list, and only show a limited number of commands with an option to expand.

Commands that have a shortcut will be listed first in the extension shortcut UI.

Limit the number of commands shown per extension in the shortcuts UI. A show
more button is included to show all of the commands for a given extension if
there are more than the limit.

Assignee: nobody → mstriemer
Priority: -- → P2
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2a2cbeecf1ca
Part 1: Sort commands by a shortcut being set r=Gijs
https://hg.mozilla.org/integration/autoland/rev/e722480c940a
Part 2: Limit commands shown in shortcuts UI to 5 r=Gijs,flod
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Attached image Bug1521826.png

I can reproduce this issue on Firefox 66.0b3(20190128143734) under Win 7 64-bit Mac OS X 10.14.1.

This issue is verified as fixed on Firefox 67.0a1(20190131093752) under Win 7 64-bit and Mac OS X 10.14.1.

Please see the attached screenshot.

Status: RESOLVED → VERIFIED

With this bug 1521826 VERIFIED FIXED, should bug 1325692 (NEW Unassigned) be updated?

I'm not sure how the two are related. I don't think this will change anything for that bug.

You need to log in before you can comment on or make changes to this bug.