Closed Bug 1522053 Opened 9 months ago Closed 8 months ago

Blocked icon and Site Information panel info are lost after moving the tab with blocked media to a new window

Categories

(Firefox :: Site Identity, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox64 --- disabled
firefox65 --- disabled
firefox66 --- verified
firefox67 --- verified

People

(Reporter: tbabos, Assigned: daleharvey)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

Attached video Video of the issue

[Affected versions]:
Nightly 66.0a1 - Build ID: 20190123070847

[Affected platforms]:
Windows 7/10 x64
Mac OS 10.14
Ubuntu 18.04

[Steps to reproduce]:

  1. Go to cnn.com/videos - the playback is blocked, blocked icon appears in the URL bar and blocked information is displayed in the Site Information panel
  2. Open several other random tabs
  3. Right click on the tab with the cnn video
  4. Select to Move Tab -> Move to New Window

[Expected]:
The Tab should be moved to a new Window as it was in the original one.

[Actual Results]:
The Blocked icon, as well as the info under Permission in the Site Information panel, are no longer displayed. The video is still blocked but the user has to refresh the page in order for the above items to be displayed again as expected.

Rank: 15
Priority: -- → P2

Hi, Dale,
Do you mind take a look for this one?
Thanks.

Flags: needinfo?(dharvey)
Component: Audio/Video: Playback → Site Identity and Permission Panels
Product: Core → Firefox

Good catch, can reproduce, I think this is related to https://bugzilla.mozilla.org/show_bug.cgi?id=1522058 and an issue with us showing the blocked icon based on an event vs based on state, I think we are likely going to want to set a property on the tab that gets cleared on refresh when we see the event, and show the UI based on that state

Assignee: nobody → dharvey
Flags: needinfo?(dharvey)

Actually I don't think I need to track this as it seems unlikely to block the feature.

ok got a working patch for thi, just need to write a test for it, looking around for one thats similiar

Status: NEW → ASSIGNED
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/56f40b43c0d4
Copy global permissions into new browsers r=johannh
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Comment on attachment 9046862 [details]
Bug 1522053 - Copy global permissions into new browsers

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: Confusing display of autoplay icon (at the wrong time)
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small patch with automated tests
  • String changes made/needed:
Attachment #9046862 - Flags: approval-mozilla-beta?

Comment on attachment 9046862 [details]
Bug 1522053 - Copy global permissions into new browsers

Fix for autoplay icon display bug, OK for beta 13 uplift.

Attachment #9046862 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified - fixed on latest Nightly 67.0a1 (2019-03-04) (64-bit) and on Beta 66.0b13 on Windows 7/10 x64, Ubuntu 16.04 and Mac OS 10.13.
Thanks for the fix Dale!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.