Closed Bug 1522082 Opened 2 years ago Closed 2 years ago

Update memory.fill encoding

Categories

(Core :: Javascript: WebAssembly, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: lth, Assigned: lth)

References

Details

Attachments

(2 files)

The current spec requires an unconditional target memory index to follow the opcode bytes, and allows for now flags. Otherwise there is no functional change.

Spec: https://github.com/WebAssembly/bulk-memory-operations/blob/master/proposals/bulk-memory-operations/Overview.md#instruction-encoding

Note, sits on top of my patch for bug 1522081.

Attachment #9038489 - Flags: review?(jseward)
Comment on attachment 9038489 [details] [diff] [review]
bug1522082-memory-fill-encoding.patch

Forgot to handle encoding in text-to-binary.
Attachment #9038489 - Flags: review?(jseward)
Attachment #9038493 - Flags: review?(jseward)
Comment on attachment 9038493 [details] [diff] [review]
bug1522082-memory-fill-encoding-v2.patch

Review of attachment 9038493 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine.  Again, as with bug 1522081, the spec seems inadequate regarding
the type of the "memory:0x00" immediate, but that strikes me as a bug in the
spec, not a bug in this patch.
Attachment #9038493 - Flags: review?(jseward) → review+
Pushed by lhansen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/38a052003414
make encoding of memory.fill standard-compliant.  r=jseward
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
See Also: → 1523081
You need to log in before you can comment on or make changes to this bug.