Closed Bug 1522120 Opened 7 months ago Closed Last month

Exit fullscreen when a permission prompt is shown to the user

Categories

(Firefox :: Site Identity and Permission Panels, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: johannh, Assigned: pbz)

References

(Depends on 1 open bug, Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(1 file)

There are various sites trapping you in fullscreen to trick and/or force you into responding to permission prompts. This is most commonly done with add-on prompts, which is why we want to disallow add-on prompts from being shown in fullscreen at all (bug 1412561).

Another more general problem is that these prompts can be easily spoofed in fullscreen, because we are lacking a browser chrome.

The add-on use case is clearly malicious, while there may be a valid reason to request other permissions for fullscreen apps, which is why I think it's too much to outright forbid it.

All in all, I think it's sensible to force-exit fullscreen and disallow re-entering while a permission prompt is shown.

Might need to be mindful of bugs like bug 1355000 when implementing this.

Depends on: 1559167
Assignee: nobody → pbz
Status: NEW → ASSIGNED
Regressions: 1568570
Keywords: checkin-needed

Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/0b99dfb9f7c7
Remove permission prompts when entering full-screen and leave full-screen when a permission prompt is shown. r=johannh

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.