Prevent assigning a shortcut that is already assigned

VERIFIED FIXED in Firefox 68

Status

()

defect
P2
normal
VERIFIED FIXED
5 months ago
3 months ago

People

(Reporter: mstriemer, Assigned: trishul.goel)

Tracking

Trunk
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 wontfix, firefox67 wontfix, firefox68 verified)

Details

Attachments

(2 attachments)

Reporter

Description

5 months ago

If a shortcut is set by Firefox, we prevent setting it for an extension, something similar should happen for shortcuts that are already set by an extension.

STR

  1. Assign a shortcut to something (like Ctrl+Alt+S)
  2. Try to assign another shortcut to the same thing (Ctrl+Alt+S)

Expected results: An error is shown, stating that this shortcut is already defined (possibly including at least one extension name that already defines it)

Actual results: The shortcut is set, but it may or may not execute the related command

Priority: -- → P2
Assignee

Comment 1

4 months ago

@mark, Can I work on this, I have an idea how to get started?

Flags: needinfo?(mstriemer)
Assignee

Comment 2

4 months ago

Prevent assigning a shortcut that is already assigned

Assignee: nobody → trishul.goel
Assignee

Updated

3 months ago
Flags: needinfo?(mstriemer)
Keywords: checkin-needed

Comment 3

3 months ago

Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a9aed50dd3eb
Prevent assigning a shortcut that is already assigned r=mstriemer,aswan,flod

Keywords: checkin-needed

Comment 4

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Comment 5

3 months ago

Thanks for solving this! Much appreciated.

Comment 6

3 months ago
Posted image Bug1522227.gif

This issue is verified as fixed on Firefox 68.0a1 (20190404215521) under Win 7 64-bit and Mac OS X 10.14.1.

Please see the attached video.

Is this bug a duplicate of Bug1520123?

Flags: needinfo?(mstriemer)

Updated

3 months ago
Status: RESOLVED → VERIFIED
Reporter

Updated

3 months ago
See Also: → 1520123
Reporter

Comment 7

3 months ago

They look like dupes, but I think we can keep it. We had identified two things we should do: notify users of duplicates and prevent more duplicates from being created. This bug solves the second case, so I've updated the other bug to solve the first case.

Flags: needinfo?(mstriemer)
You need to log in before you can comment on or make changes to this bug.