Closed Bug 1522428 Opened 8 months ago Closed 6 months ago

Enable tagging glean pings for the "debug view"

Categories

(Toolkit :: Telemetry, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Tracking Status
firefox66 --- affected

People

(Reporter: Dexter, Assigned: tlong)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [telemetry:mobilesdk:m8])

Attachments

(1 file)

62 bytes, text/x-github-pull-request
Details | Review

The "debug view" will allow to inspect a sample of the glean pings sent by glean consumer applications in real-time, on our CEP.

This bug is about enabling this in the SDK, allowing to tag outgoing pings so that the CEP can tell them apart.

Blocks: 1491345
Priority: -- → P3
Whiteboard: [telemetry:mobilesdk:m?]
Depends on: 1522430
Duplicate of this bug: 1507843
Whiteboard: [telemetry:mobilesdk:m?] → [telemetry:mobilesdk:m8]
Assignee: nobody → tlong

The name of the header was finalized, it's X-Debug-ID, see here. This will need to be attached to outgoing http uploads. Its value would be a string provided by the user through he GleanDebugActivity.

@Travis, in addition to sending pings to the default ingestion endpoint, while we're transitioning to the new pipeline, we will need to send the pings triggered with "X-Debug-ID" to a separate ingestion endpoint, in addition to the endpoint in the configuration object. This means we'll send the same pings twice. It's ok to take on this part as follow-up work, if needed.

@Frank, can you provide us with the ingestion endpoint for GCP?

Flags: needinfo?(fbertsch)
Status: NEW → ASSIGNED
Priority: P3 → P1

Another solution is to send the "debug tagged" pings only to GCP.
Frank or Arkadiusz should follow up on what we prefer.

Flags: needinfo?(akomarzewski)
Attached file GitHub Pull Request

PR adding the ping tagging is now in-flight

I'll add the extra upload mechanism once I know the endpoint URL. Does this mean we are redirecting all 'tagged' pings to the GCP endpoint, or we are going to send all 'tagged' pings to both (and 'un-tagged' pings don't go to GCP)?

<edit> I should have refreshed my page before posting, Georg asked almost the same thing :D. Any clarification on how we would like to divert/split/send in duplicate the pings is appreciated!

We don't want to duplicate pings as that would complicate pipeline side a lot.

Let's send tagged pings directly to GCP (untagged go to standard endpoint).
I'd also add a config option that would switch the endpoint back to standard AWS one (just in case we discover something's wrong with new edge, we don't need to document that for users). We'd also need to make a note to clear this after we're done moving to GCP.

Flags: needinfo?(akomarzewski)
Flags: needinfo?(fbertsch)

Referencing this here since it contained some specs that I didn't know about, like the constraints on the debug ID

Debug View

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.