Derive more and shrink repr(c) representation of MaxLength / MozLength.

RESOLVED FIXED in Firefox 67

Status

()

defect
P2
normal
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: emilio, Assigned: emilio)

Tracking

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

3 months ago
Depends on: 1523071
(Assignee)

Comment 1

3 months ago

This patch:

  • Makes LengthPercentageOrAuto generic, and removes a bunch of code fo
    LengthPercentageOrNone, which was used only for servo and now can use the
    normal MaxLength (with a cfg() guard for the ExtremumLength variant).

  • Shrinks MaxLength / MozLength's repr(C) reperesentation by reducing enum
    nesting. The shrinking is in preparation for using them from C++ too, though
    that'd be a different bug.

  • Moves NonNegative usage to the proper places so that stuff for them can be
    derived.

I did this on top of bug 1523071 to prove both that it could be possible and
that stuff wasn't too messy. It got a bit messy, but just because of a bug I
had fixed in bindgen long time ago already, so this updates bindgen's patch
version to grab a fix instead of ugly workarounds :)

(Assignee)

Updated

3 months ago
Duplicate of this bug: 1499228
Priority: -- → P2

Comment 4

2 months ago
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/5a801f6c5c8f
Derive more length stuff, and shrink MaxLength / MozLength's repr(C) representation. r=boris
(Assignee)

Updated

2 months ago
Blocks: 1526736

Comment 5

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.