Add-on card in about:addons is broken with longer translation

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
7 months ago
7 months ago

People

(Reporter: flod, Assigned: mstriemer)

Tracking

(Blocks 1 bug)

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 verified)

Details

Attachments

(5 attachments)

Posted image immagine.png

The label is cut, which is kind of expected. I wasn't expecting the button to fall out of the card though.

Summary: Add-on card is broken with longer translation → Add-on card in about:addons is broken with longer translation
Priority: -- → P1

(In reply to Francesco Lodolo [:flod] from comment #0)

The label is cut, which is kind of expected.

To be clear, we really shouldn't cut this either.

Assignee: nobody → mstriemer

So on Beta the details card is fine, it expands in width a little to fit the automatic updates row. On Nightly, once it expands it gets scrollbars instead and the content is "hidden".

This is because the error/warning containers now have a max-width and that becomes where the scrollbar goes, instead of at the full width of (the rest of) the pane.

Component: General → Add-ons Manager
Product: WebExtensions → Toolkit
Attachment #9039878 - Attachment description: Bug 1523632 - Wrap the extension private browsing label on details page r?mixedpuppy,flod → Bug 1523632 - Part 1: Wrap the extension private browsing label on details page r?mixedpuppy,flod
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ea5bca13b8d2
Part 1: Wrap the extension private browsing label on details page r=mixedpuppy,flod
https://hg.mozilla.org/integration/autoland/rev/c19692b8561d
Part 2: Allow detail cards to expand without scrollbars r=mixedpuppy
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Posted image Bug1523632-IT.png

I can reproduce this issue on Firefox 67.0a1 - it (20190129103321) under Win 7 64-bit.

This issue is verified as fixed on Firefox 67.0a1 - it (20190130094929) under Win 7 64-bit and Mac OS X 10.14.1.

Please see the attached screenshot.

Status: RESOLVED → VERIFIED
Posted image Bug1523632-RU.png

I also noticed that for Japanese and Russian builds (probably for more builds), the “Run in Private Windows” is not translated.

Is this expected Mark?

Flags: needinfo?(mstriemer)

(In reply to CosminB from comment #8)

Created attachment 9040111 [details]
Bug1523632-RU.png

I also noticed that for Japanese and Russian builds (probably for more builds), the “Run in Private Windows” is not translated.

It is (Nightly is localized only by a handful of locales)

Flags: needinfo?(mstriemer)
You need to log in before you can comment on or make changes to this bug.