enable toggling private browsing in about:addons

VERIFIED FIXED in Firefox 67

Status

enhancement
P1
normal
VERIFIED FIXED
5 months ago
25 days ago

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

Tracking

(Blocks 1 bug, {dev-doc-needed})

unspecified
mozilla67
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 67+, firefox67 verified)

Details

Attachments

(6 attachments, 5 obsolete attachments)

(Assignee)

Description

5 months ago
Bug 1457001 has a lot of conversation going on, this bug is for the actual work effort.
(Assignee)

Comment 2

5 months ago
Comment on attachment 9029151 [details]
Bug 1511636 toggle private browsing via about:addons

This is a very rough draft/wip patch where I'm trying to hookup a value from about:addons into the Extension class.  There are a few area's in XPI stuff I'm not super familiar with, some input would be appreciated.
Attachment #9029151 - Flags: feedback?(aswan)
(Assignee)

Updated

4 months ago
Assignee: nobody → mixedpuppy
Priority: -- → P1
(Assignee)

Comment 3

4 months ago
We'll change the text to "Private Browsing  On Off".  Need text for the description line underneath.  That text will be sized/colored as the second line under prefs (see general->performance).
Flags: needinfo?(emanuela)
(Assignee)

Updated

4 months ago
Duplicate of this bug: 1513345

Updated

4 months ago
Flags: needinfo?(emanuela)
(Assignee)

Comment 5

4 months ago
aswan for startupData changes.  rpl for everything.
Comment on attachment 9029151 [details]
Bug 1511636 toggle private browsing via about:addons

Switching f? to ni? so I don't lose track of this
Flags: needinfo?(aswan)
Attachment #9029151 - Flags: feedback?(aswan)
Attachment #9031240 - Attachment description: Bug 1511636: update incognito schema and support system addons → Bug 1511636: update incognito support to use pref and permissions
(Assignee)

Comment 8

4 months ago
Mark, who do you ping for support urls?  i.e. Learn More links in preferences.
Flags: needinfo?(mstriemer)
(Assignee)

Updated

4 months ago
Blocks: 1516548
(Assignee)

Comment 9

4 months ago
Banner is being worked on in bug 1516548.  This is a request for alpha on the disabled tag.  I used rgba(128,0,215,.5) for disabled state, rgb(128,0,215) for enabled state.
Attachment #9033423 - Flags: feedback?(emanuela)
(Assignee)

Updated

4 months ago
Duplicate of this bug: 1457001
(Assignee)

Updated

4 months ago
Depends on: 1516655

Comment 11

4 months ago
@Shane, (In reply to Shane Caraveo (:mixedpuppy) from comment #8)
> Mark, who do you ping for support urls?  i.e. Learn More links in
> preferences.


We can get the URL from Joni, I believe.
Flags: needinfo?(jsavage)
> We can get the URL from Joni, I believe.

Yes, here's a link you can use: https://support.mozilla.org/1/firefox/%VERSION%/%OS%/%LOCALE%/extensions-pb

It will automatically direct to a SUMO article (no content yet).
Flags: needinfo?(jsavage)
Flags: needinfo?(mstriemer)

Updated

3 months ago
Flags: needinfo?(aswan)

Comment 13

3 months ago

(In reply to Shane Caraveo (:mixedpuppy) from comment #9)

Created attachment 9033423 [details]
Screen Shot 2018-12-27 at 12.12.29 PM.png

Banner is being worked on in bug 1516548. This is a request for alpha on
the disabled tag. I used rgba(128,0,215,.5) for disabled state,
rgb(128,0,215) for enabled state.

Almost there!

We need to move the tag below the description. Be sure to keep the text all caps.

Regarding the color, it's rgba(98, 0, 164, 1) for the enabled state and rgba(98, 0, 164, 0.4) for the disabled one.

Updated

3 months ago
Attachment #9033423 - Flags: feedback?(emanuela) → feedback-
(Assignee)

Comment 14

3 months ago
Posted image extensions list view (obsolete) —
Attachment #9033423 - Attachment is obsolete: true
Attachment #9035923 - Flags: feedback?(emanuela)
(Assignee)

Comment 15

3 months ago
Posted image details view (obsolete) —
Attachment #9035925 - Flags: feedback?(emanuela)
(Assignee)

Comment 16

3 months ago

hrm, I think a change I did in reaction to review feedback resulted in the text getting larger on the details view. will fix.

(Assignee)

Comment 17

3 months ago
Posted image details view (obsolete) —

There, that's better.

The primary descriptions here are 1.36em (on osx). I've made the second line 1.1rem

Attachment #9035925 - Attachment is obsolete: true
Attachment #9035925 - Flags: feedback?(emanuela)
Attachment #9035937 - Flags: feedback?(emanuela)

Comment 18

3 months ago

Comment on attachment 9035923 [details]
extensions list view

The label is perfect, thank you!

Extensions icons and the buttons need to maintain the same positions they have when the label is not present.

Attachment #9035923 - Flags: feedback?(emanuela) → feedback-

Comment 19

3 months ago

Comment on attachment 9035937 [details]
details view

Closer!

I have some notes.

  1. The color of the description seems very light for such a small font-size. I will suggest using ##4a4a4f (grey-60)

  2. The color of the link seems off. I suggest #0060df (aka blue-60) and to make the link underline. If other links are present on the page, we should make all the links looks like this.

  3. Can I see a screen with a full card? I need to understand if there is enough space around the description.

Attachment #9035937 - Flags: feedback?(emanuela) → feedback-
(Assignee)

Comment 20

3 months ago
Posted image full card (obsolete) —

I had to use a test extension to get a full card screenshot, let me know if this gives enough visual info for you.

Attachment #9035949 - Flags: feedback?(emanuela)
(Assignee)

Comment 21

3 months ago

(In reply to emanuela [ux] [OOO 12/21 - 01/07] from comment #19)

  1. The color of the description seems very light for such a small font-size. I will suggest using ##4a4a4f (grey-60)

  2. The color of the link seems off. I suggest #0060df (aka blue-60) and to make the link underline. If other links are present on the page, we should make all the links looks like this.

The sub-description is new, so changes there would not affect anything else. However, the link color, underline, etc. would either globally affect about:addons, or make this link different than other locations we have "learn more". I think the style is also shared with other links (e.g. author, homepage) as they appear the same, but I haven't verified. Hovering over these links darkens and underlines them.

If we want to make global changes, I'd prefer to have that as a separate bug so I don't have to examine every possibility

Flags: needinfo?(emanuela)
(Assignee)

Comment 22

3 months ago
  1. The color of the link seems off. I suggest #0060df (aka blue-60)

All links in about:addons are defined as var(--in-content-link-color) in css, which is 0a8dff. On hover it changes to #0060df.

Comment 23

3 months ago

the link color, underline, etc. would either globally affect about:addons, or make this link different than other locations we have "learn more". I think the style is also shared with other links (e.g. author, homepage) as they appear the same, but I haven't verified. Hovering over these links darkens and underlines them.

If we want to make global changes, I'd prefer to have that as a separate bug so I don't have to examine every possibility

Agree. Let's track it in a separate bug, which should not block this one.

Flags: needinfo?(emanuela)
(Assignee)

Comment 24

3 months ago
Posted image extensions list view
Attachment #9035923 - Attachment is obsolete: true
Attachment #9035984 - Flags: feedback?(emanuela)
(Assignee)

Comment 25

3 months ago
Posted image full details card
Attachment #9035937 - Attachment is obsolete: true
Attachment #9035949 - Attachment is obsolete: true
Attachment #9035949 - Flags: feedback?(emanuela)
Attachment #9035985 - Flags: feedback?(emanuela)
(Assignee)

Updated

3 months ago
See Also: → 1519488

Comment 26

3 months ago

Comment on attachment 9035984 [details]
extensions list view

Looks good to me.

Attachment #9035984 - Flags: feedback?(emanuela) → feedback-

Comment 27

3 months ago

Comment on attachment 9035985 [details]
full details card

Nice! The contrast is way better now. Thank you

Attachment #9035985 - Flags: feedback?(emanuela) → feedback-

Updated

3 months ago
Attachment #9035984 - Flags: feedback- → feedback+

Updated

3 months ago
Attachment #9035985 - Flags: feedback- → feedback+

Updated

3 months ago
Blocks: 1522918

Comment 30

3 months ago
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/26ac80bf3391
update ExtensionPermissions to take id instead of extension instance, r=aswan,rpl
https://hg.mozilla.org/integration/autoland/rev/9553d0cc4eea
update incognito support to use pref and permissions r=rpl,aswan,kmag
https://hg.mozilla.org/integration/autoland/rev/ba4db0fbeb24
toggle private browsing via about:addons r=rpl,mstriemer,flod,kmag

Comment 31

3 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Depends on: 1523632

Comment 32

3 months ago
Posted image Bug1511636.png

This issue is verified as fixed on Firefox 67.0a1 (20190130001444) under Win 7 64-bit and Mac OS X 10.14.1.

The preference ‘extensions.allowPrivateBrowsingByDefault’ is set to true by default.

When the preference is set to true, the extensions are enabled by default in private windows.
When the preference is set to false, the extensions are not enabled by default in private windows.

Please see the attached screenshot.

Updated

3 months ago
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1534107
Depends on: 1538583
Depends on: 1538546
No longer depends on: 1538546
You need to log in before you can comment on or make changes to this bug.