Create BrowsingContext in nsFrameLoader

RESOLVED FIXED in Firefox 68

Status

()

enhancement
P2
normal
RESOLVED FIXED
4 months ago
5 days ago

People

(Reporter: Nika, Assigned: farre)

Tracking

(Blocks 4 bugs)

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Fission Milestone:M2, firefox68 fixed)

Details

Attachments

(1 attachment)

Currently the browsing context for a nsFrameLoader is set asynchronously from the TabChild when out-of-process. We should instead send down the BrowsingContext when constructing the TabParent object, rather than creating the BrowsingContext in-process. This will also be good for out-of-process iframes.

Assignee

Updated

3 months ago
Assignee: nobody → afarre

Updated

3 months ago
Status: NEW → ASSIGNED
Fission Milestone: --- → M2
Assignee

Updated

3 months ago
Duplicate of this bug: 1467227

Updated

3 months ago
Blocks: 1467214
Component: DOM → DOM: Core & HTML
Product: Core → Core
Attachment #9053870 - Attachment description: Bug 1523636 - Create BrowsingContext in nsFrameLoader. → Bug 1523636 - Create BrowsingContext in nsFrameLoader. r=nika
Assignee

Updated

2 months ago
Blocks: 1541891
Assignee

Updated

2 months ago
Depends on: 1542204

Comment 3

2 months ago
Pushed by afarre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d76b42f0d6ca
Create BrowsingContext in nsFrameLoader. r=nika,qdot

Comment 4

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Regressions: 1543015
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla68 → ---

Updated

2 months ago
Whiteboard: [4/11] backed out because of bug 1543015. Working on the fix.
Assignee

Updated

a month ago
Blocks: 1543937

Comment 6

a month ago
Pushed by afarre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1ed5db9c200a
Create BrowsingContext in nsFrameLoader. r=nika,qdot

Comment 7

a month ago
bugherder
Status: REOPENED → RESOLVED
Last Resolved: 2 months agoa month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Updated

a month ago
Whiteboard: [4/11] backed out because of bug 1543015. Working on the fix.
Regressions: 1546454
You need to log in before you can comment on or make changes to this bug.