Back button history menu "floats" and sometimes isn't dismissed

VERIFIED DUPLICATE of bug 102330

Status

()

Core
XUL
--
minor
VERIFIED DUPLICATE of bug 102330
16 years ago
9 years ago

People

(Reporter: neilio, Assigned: David Hyatt)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I've noticed that the back button history (when you click the tiny down arrow to
the right of the back button) sometimes isn't dismissed when a selection is made
from it. One way to reproduce this every time is:

i) get a bit of browsing history so you actually get a history menu
ii) click and hold on the "show back history menu" arrow. The menu appears -
keep holding. The menu should flash for a split second; it's now 'stuck' and you
can move the main window around independently from the back menu.

The only way to get rid of the menu is to actually click on one of the history
states.

(see attachment for screencapture)
(Reporter)

Comment 1

16 years ago
Created attachment 88022 [details]
Screencature of problem

Updated

16 years ago
Keywords: qawanted
Whiteboard: DUPEME

Comment 2

16 years ago
Confirmed using FizzillaCFM/2002061014. See also bug 137201 and bug 101472.

Reassigning to XP Toolkit/Widgets: Menus and reducing Severity to Minor since
the workaround is to dismiss the pop-up menu with the escape key.
Assignee: Matti → hyatt
Severity: normal → minor
Component: Browser-General → XP Toolkit/Widgets: Menus
QA Contact: imajes-qa → shrir

Comment 3

16 years ago
Really confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago
There are two bugs here.
(1) When your computer is trying to do lots of stuff at once, Mozilla thinks that
    a click is a click-and-hold. That's bug 117589.
(2) When you do a click-and-hold on the Back menubutton, one copy of the Back menu 
    opens because you clicked on the menubutton, and another copy of the menu
    opens because you clicked-and-held on the Back button (which includes the
    menubutton). That's bug 102330. Then when you choose an item from the
    frontmost copy of the menu, the other copy stays behind.

*** This bug has been marked as a duplicate of 102330 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Comment 5

15 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.