~/.mozilla/appreg contains a bogus value for the user profile directory

VERIFIED DUPLICATE of bug 154054

Status

--
major
VERIFIED DUPLICATE of bug 154054
17 years ago
3 years ago

People

(Reporter: andrew.lynch, Assigned: ccarlen)

Tracking

Trunk
Sun
SunOS

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build 2002061401 (1.1a)

After a crash, ~/.mozilla/appreg contains a bogus value for the user profile
directory.  The correct value loses the last character ( ie: 
/home/andrewl/.mozilla/default/y0rem95g.slt becomes
/home/andrewl/.mozilla/default/y0rem95g.sl  
).

Profile manager then fails to find the correct profile directory, and cannot
access that profile.

From truss:
...
5182:
access("/home/andrewl/.mozilla", 0)		= 0
5182:
open("/home/andrewl/.mozilla/appreg", O_RDWR)	= 9
5182:
access("/home/andrewl/.mozilla/default/y0rem95g.", 0) Err#2 ENOENT
5182:
access("/home/andrewl/.mozilla/inspector/71qp9l6e.slt", 0) = 0
5182:
access("/home/andrewl/.mozilla/andrewl/skg00s1r.slt", 0) = 0
5182:
access("/home/andrewl/.mozilla", 0)		= 0
...

Comment 1

17 years ago
Yup, confimed on 20020626 Solaris 10, SPARC. Initially I thought that appreg was
only getting corrupted following a moz crash, but I've just had it happen
following a clean exit.

Workaround: keep a copy of appreg somewhere :)

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Also happens for Mozilla 1.0 (build 2002061318) on both Solaris 7 and 8.

Comment 3

17 years ago
*** Bug 154758 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
resolving as dup of bug 154054 - there's more info there

*** This bug has been marked as a duplicate of 154054 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.