Closed Bug 1524908 Opened 3 years ago Closed 3 years ago

One off search buttons are broken after customize (duplicate rows)

Categories

(Firefox :: Search, defect, P1)

67 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 + verified

People

(Reporter: euthanasia_waltz, Assigned: mikedeboer)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached image (screenshot)

STR:

  1. Start nightly with new profile
  2. Enter customize mode (right-click on tab-bar, click "Customize")
  3. Chenge theme and exit customize mode
  4. Type something in address-bar

AR:
Search engine icons are displayed twice or more.(see screenshot)

mozregression result:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=9658187a54fbd9e7c5bda51fb4e5a041a7af77be&tochange=add76bbdce4e452d1f921bcbc1224b30892d8393

Attached image (screenshot)

Another STR:

  1. Start nightly with new profile
  2. Remove flexible-spaces around address-bar
  3. Type something in address-bar

AR:
(see screenshot)

Blocks: 1524593
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

[Tracking Requested - why for this release]: Obvious visual regression

Severity: normal → major
Flags: needinfo?(mdeboer)
Priority: -- → P1
Summary: Search suggestion dropdown is broken after customize → Search suggestion dropdown is broken after customize (duplicate rows)
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Flags: needinfo?(mdeboer)
Blocks: 1517486
Duplicate of this bug: 1525322
Summary: Search suggestion dropdown is broken after customize (duplicate rows) → One off search buttons are broken after customize (duplicate rows)
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0a5768488340
Since the Search Service API is now asynchronous, the one-off-search (re)build method became re-entrant and evidently race-y. Let's guard against that. r=dao
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a72cce99f449
Since the Search Service API is now asynchronous, the one-off-search (re)build method became re-entrant and evidently race-y. Let's guard against that. r=dao

Fixed test and relanded.

Flags: needinfo?(mdeboer)
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

I have reproduced this bug with Nightly 67.0a1 (2019-02-03) on Windows 10, 64 Bit. The fix of this bug is verified with latest Nightly 67.0a1!

Build ID : 20190211215545
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

QA Whiteboard: [bugday-20190206]

I will mark this bug as Verified Fixed as per comment 12.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.