Closed Bug 1525185 Opened 9 months ago Closed 4 months ago

[about:addons] Confirm that all the telemetry is still there

Categories

(Toolkit :: Add-ons Manager, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox67 --- disabled
firefox68 + fixed
firefox69 --- fixed

People

(Reporter: mstriemer, Assigned: mstriemer)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [feature-scope])

Attachments

(1 file)

Telemetry should be added to views as they're converted, but we should audit what has been setup to confirm that nothing was removed.

Whiteboard: [feature-scope]
Blocks: 1533795
No longer blocks: 1505924
Priority: P2 → P1
Summary: Confirm that all the telemetry is still there → [about:addons] Confirm that all the telemetry is still there
Assignee: nobody → mstriemer
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a02341b39691
Telemetry for HTML about:addons r=mixedpuppy,rpl
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

This targets 68 (and needs to be uplifted).

Comment on attachment 9065885 [details]
Bug 1525185 - Telemetry for HTML about:addons r?rpl

Beta/Release Uplift Approval Request

  • User impact if declined: Telemetry will be missing from some HTML about:addons actions.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: bug 1557944
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This uses the existing helper methods from the XUL about:addons to record telemetry for the HTML version. These helpers cannot throw.
  • String changes made/needed: No
Attachment #9065885 - Flags: approval-mozilla-beta?
Regressions: 1557944

Comment on attachment 9065885 [details]
Bug 1525185 - Telemetry for HTML about:addons r?rpl

approved for 68.0b10

Attachment #9065885 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify-

There are conflicts while merging to beta.
toolkit/mozapps/extensions/content/aboutaddons.js

:mstriemer , can you please take a look?

Flags: needinfo?(mstriemer)

This patch depends on changes from bug 1550911.

According to the last relman comment on that bug, that patch will be uplifted when some translations are ready.

Flags: needinfo?(mstriemer)
Blocks: 1558896
You need to log in before you can comment on or make changes to this bug.