Closed Bug 1557944 Opened 4 months ago Closed 4 months ago

Intermittent toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | ask-to-activate is checked -

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: robwu)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell unknown])

Attachments

(1 file)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=250763087&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/SvLJSWylT0C0Tsl6j8NlSw/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/SvLJSWylT0C0Tsl6j8NlSw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


11:31:34 INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | ask-to-activate is enabled -
11:31:34 INFO - Buffered messages finished
11:31:34 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | ask-to-activate is checked -
11:31:34 INFO - Stack trace:
11:31:34 INFO - chrome://mochikit/content/browser-test.js:test_ok:1313
11:31:34 INFO - chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_html_plugins.js:checkItems:36
11:31:34 INFO - chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_html_plugins.js:testAskToActivate:58
11:31:34 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1115
11:31:34 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1143
11:31:34 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:999
11:31:34 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
11:31:34 INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | always-activate is enabled -
11:31:34 INFO - Not taking screenshot here: see the one that was previously logged
11:31:34 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | always-activate isn't checked -
11:31:34 INFO - Stack trace:
11:31:34 INFO - chrome://mochikit/content/browser-test.js:test_ok:1313
11:31:34 INFO - chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_html_plugins.js:checkItems:38
11:31:34 INFO - chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_html_plugins.js:testAskToActivate:58
11:31:34 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1115
11:31:34 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1143
11:31:34 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:999
11:31:34 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
11:31:34 INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | never-activate is enabled -
11:31:34 INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | never-activate isn't checked -
11:31:34 INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | preferences is enabled -
11:31:34 INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | preferences isn't checked -
11:31:34 INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | expand is enabled -
11:31:34 INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | expand isn't checked -
11:31:34 INFO - Not taking screenshot here: see the one that was previously logged
11:31:34 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/browser/browser_html_plugins.js | Flash is ask-to-activate - Got false, expected askToActivate

After investigating this, it seems that the fail first appeared on this push: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=a02341b39691e55e9683aaf000f00b12a11c7a2b&selectedJob=250726398&searchStr=4a2d8dfee77305ca3ddbcb977cd92cce17199e1e

Mark, could this be a regression from your push?

Flags: needinfo?(mstriemer)
Regressed by: 1525185

I wouldn't worry too much about this right now, the test is about to be updated in bug 1519434.

This fails consistently when repeated, because the test expects a certain initial state, which differs from the state at the end of the test.

Assignee: nobody → rob
Status: NEW → ASSIGNED
Flags: needinfo?(mstriemer)
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/ff295148b44c
Fix intermittent browser_html_plugins.js r=rpl
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

From my understanding this issue is related to the automated tests. Is there any need of manual QA here? If not can you please mark it as "qe-verify- "

Flags: needinfo?(rob)
Flags: needinfo?(rob)
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.