Closed Bug 15255 Opened 20 years ago Closed 20 years ago

Tweak-UI's X-Mouse conflicts with Menu bars and Option Lists

Categories

(Core :: User events and focus handling, defect, P3, minor)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 16037

People

(Reporter: rrothenberg, Assigned: joki)

References

()

Details

I have the Tweak-UI power toy on Windows NT 4.0 SP5 Workstation with X-Mouse
enabled and drop-down lists in the menu bars as well as option lists in forms
cannot be selected.

When X-Mouse is unchecked in Tweak-UI, menus can be selected. Have been able
to reproduct this bug.

Mozilla nightly build 199092909
QA Contact: claudius → cpratt
Severity: blocker → minor
Component: UE/UI → Event Handling
This is possibly related to bug 12422. cc'ing joki.

Changing severity to minor as these are "unsupported tools" (cf. Microsoft's Web
site).
btw, for those that don't have Tweak UI 1.1, it is available at:
http://www.microsoft.com/NTWorkstation/downloads/PowerToys/Networking/NTTweakUI.
asp
This bug is valid and reproducible.

It also reminds me of another problem I have seen (I don't know if a bug exists
for that behavior): without Tweak UI installed on NT, if you click once to drop
down a menu, and then click on a submenu header to reveal the submenu, the menu
goes away.

There is a workaround for this problem in the meantime: click and hold when
selecting menus and menu items. If you release the mouse button after clicking
on a menu, mousing over items will dismiss the menu. If you keep the mouse
button depressed, you are still able to select submenus and menu items. Sorry
for the inconvenience.
Assignee: shuang → joki
I don't know what to do with it. Joki, re-assign it to you to take care of it.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 16037 ***
Status: RESOLVED → VERIFIED
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.