Closed Bug 1525533 Opened 10 months ago Closed 9 months ago

[remote-dbg-next] Stop using the Browser Toolbox to debug local addons

Categories

(DevTools :: about:debugging, enhancement, P1)

enhancement

Tracking

(firefox67 fixed)

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- fixed

People

(Reporter: jdescottes, Assigned: daisuke)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

webextensions are now running out of process, so in theory we can now debug them using a regular toolbox rather than a browser toolbox.

My current issues with using the browser toolbox are:

  • it is slower to open
  • only one can be opened at a time
  • it uses confusing profile settings for addon developers
  • it prevents from having a unified debugging UX in about:debugging, where we could in theory debug everything with about:devtools-toolbox tabs.
  • it forces to enable remote debugging to debug local addons. We also have to maintain a UI for this in about:debugging ("enable addon debugging" checkbox)

If we stop using the browser toolbox, we will however have to rewrite our current mochitests that assert debugging webextensions.

In the future, we want to list processes in about:debugging as well. If we want to stop using the Browser Toolbox, it means we won't be able to debug the Main Process for this-firefox, but I think this limitation is acceptable.

This relates to the overall issue of about:debugging having too many inconsistent workflows (toolbox in a tab, toolbox in a window, toolbox in a new firefox instance). Another way to tackle this would be to go the opposite way and use the Browser Toolbox for everything. We should discuss pros and cons of both strategies.

Duplicate of this bug: 1373219
Priority: -- → P3
Duplicate of this bug: 1522043
Assignee: nobody → dakatsuka
Status: NEW → ASSIGNED
Priority: P3 → P1
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6dadc0b70109
Debug local addon as well via debugger client. r=jdescottes
https://hg.mozilla.org/integration/autoland/rev/9cc065c29f51
Stop supporting inspection of addon in Browser Toolbox. r=jdescottes,rpl
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Duplicate of this bug: 1514215
Duplicate of this bug: 1529039
Duplicate of this bug: 1318174
You need to log in before you can comment on or make changes to this bug.