Closed Bug 1525737 Opened 4 years ago Closed 2 years ago

Remove XUL grid implementation

Categories

(Core :: XUL, task, P5)

task

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox85 --- fixed

People

(Reporter: ntim, Assigned: ntim)

References

(Blocks 1 open bug)

Details

Attachments

(5 files)

rm -rf layout/xul/grid

Depends on: tb-burn-xul-grids
Priority: -- → P5
Type: enhancement → task

Depends on D53296

Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Assignee: ntim.bugs → nobody
Status: ASSIGNED → NEW
Depends on: 1583696
Attached patch additonal fixSplinter Review

FYI, this is also needed, otherwise the linter complains the path does not exist.

Attached patch additonal fix 2Splinter Review

... and a few more things that can be removed.

Comment on attachment 9185052 [details] [diff] [review]
additonal fix 2

Review of attachment 9185052 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for catching the unused bits!

::: layout/style/test/test_non_content_accessible_values.html
@@ -12,5 @@
>    ],
>    "display": [
> -    "-moz-grid",
> -    "-moz-grid-group",
> -    "-moz-grid-line",

I kept those originally because you don't want to expose these values to content even if the code is removed. That's probably an unlikely future issue though, so up to you whether you want to remove them.

(In reply to Tim Nguyen :ntim from comment #7)

I kept those originally because you don't want to expose these values to
content even if the code is removed.

There's not much value in testing display keywords that no longer exist in the style system, so I think we should remove them from this test. I don' think there's any risk that we'd add them back by accident.

We should probably let bug 1583696 bake for a while before landing this though, just in case some regression is found.

Blocks: 1597027
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED

Hi Richard & Magnus,

Just a heads up that there are XUL grid usages in the mail/extensions/openpgp directory.
There are also quite a few in the editor/ & suite/ directories, but I was told before this isn't maintained/used for TB?

If nothing goes wrong, this bug should land in Firefox 85. Thanks to everyone involved in helping make this a reality!

Flags: needinfo?(richard.marti)
Flags: needinfo?(mkmelin+mozilla)

Thanks, I filed bug 1677427 about the final bits in Thunderbird. Yes, editor/ and suite/ are practically dead, and not used by Thunderbird.

Flags: needinfo?(richard.marti)
Flags: needinfo?(mkmelin+mozilla)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0bacd1b4ff62
Remove/replace usages of XUL grid display values. r=emilio
https://hg.mozilla.org/integration/autoland/rev/044d198df333
Remove support for XUL grid display values. r=emilio
https://hg.mozilla.org/integration/autoland/rev/517f352dbde7
Remove layout/xul/grid directory. r=emilio
Blocks: 1466170
You need to log in before you can comment on or make changes to this bug.