Use browser:purge-sessionStorage instead of extension:purge-sessionStorage in SiteDataManager.jsm

VERIFIED FIXED in Firefox 66

Status

()

defect
P1
normal
VERIFIED FIXED
6 months ago
5 months ago

People

(Reporter: johannh, Assigned: johannh)

Tracking

({regression})

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 verified, firefox67 verified)

Details

Attachments

(1 attachment)

No description provided.
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c948bb3bd63b
Use browser:purge-sessionStorage instead of extension:purge-sessionStorage in SiteDataManager.jsm. r=asuth
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Comment on attachment 9041961 [details]
Bug 1525763 - Use browser:purge-sessionStorage instead of extension:purge-sessionStorage in SiteDataManager.jsm. r=baku,asuth

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1483440

User impact if declined

Clearing site data in the site data manager doesn't clear sessionStorage

Is this code covered by automated tests?

No

Has the fix been verified in Nightly?

No

Needs manual test from QE?

Yes

If yes, steps to reproduce

  • Visit a site with sessionStorage (like https://edition.cnn.com/)
  • View sessionStorage in DevTools (keep it open)
  • Open the Site Data Manager in about:preferences and delete storage for edition.cnn.com
  • Refresh the sessionStorage in devtools using the little refresh arrow icon
  • Most sessionStorage should disappear (there may be storage left over that is being immediately reset by the page, like in my case "beemray_id4")

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

Just a typo fix

String changes made/needed

None

Attachment #9041961 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Whiteboard: [qa-triaged]

I have managed to reproduce the issue using Fx67.0a1 buildID: 20190206215551.

The issue is verified fixed using Fx67.0a1 buildID: 20190213213409 on Ubuntu 16.04, macOS 10.12 and Windows 10. Most of the session storage is cleared, only 'beemray_id4' remains but is reset by the page as mentioned in c#4.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment on attachment 9041961 [details]
Bug 1525763 - Use browser:purge-sessionStorage instead of extension:purge-sessionStorage in SiteDataManager.jsm. r=baku,asuth

Typo fix for session storage, verified in Nightly.
OK for uplift for beta 8.

Attachment #9041961 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

The issue is also verified fixed using Fx66.0b8 on Ubuntu 18.04, Windows 10 and macOS 10.14.

QA Whiteboard: [qa-triaged]
Whiteboard: [qa-triaged]
You need to log in before you can comment on or make changes to this bug.