Closed Bug 1525833 Opened 3 years ago Closed 3 years ago

Can't add searchplugins from search bar (autodiscovery)

Categories

(Firefox :: Search, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- fixed

People

(Reporter: flod, Assigned: mikedeboer)

References

Details

(Keywords: regression)

Attachments

(1 file)

In Nightly it's not possible to add searchplugins from the search bar anymore (nothing happens).

  1. Enable the search bar

  2. Go to https://l10n.mozilla-community.org/~flod/testsp/ and try to install one of the two searchplugins

  3. Console reports:

addEngine: Error adding engine:
2 nsSearchService.js:230

It would be good to confirm, but I assume this is caused by bug 1524593. Works fine in Beta.

Thanks for reporting this, Francesco. Will fix soon.

Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Priority: -- → P1

This also officially gets rid of the nsIBrowserSearchInitObserver and nsISearchInstallCallback
from nsISearchService.idl, even though they're not used for anything anymore.

Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/33b3cd76b206
nsISearchService::addEngine does not support using a callback anymore, instead it returns a Promise. Update the searchbar's usage to reflect this. r=florian
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Duplicate of this bug: 1530086
You need to log in before you can comment on or make changes to this bug.