windows/aarch64 - Invalid test mar file - toolkit/mozapps/update/tests/*

RESOLVED FIXED in Firefox 67

Status

()

defect
P5
normal
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: intermittent-bug-filer, Assigned: rstrong)

Tracking

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(2 attachments)

Same error also observed for various files such as:

  • toolkit/mozapps/update/tests/browser/browser_aboutDialog_fc_downloadOptIn_staging.js
  • toolkit/mozapps/update/tests/browser/browser_aboutDialog_fc_patch_completeBadSize_complete.js
  • toolkit/mozapps/update/tests/browser/browser_aboutDialog_fc_patch_partialBadSize_complete.js

here is more context:
03:43:22 INFO - Console message: AUS:SVC Downloader:onStopRequest - attempting to stage update: App Update Test
03:43:22 INFO - Console message: AUS:SVC readStatusFile - status: failed: 39, path: C:\ProgramData\Mozilla\updates\B4A3EEF2ED7784F0\updates\0\update.status
03:43:22 INFO - Console message: AUS:SVC readStringFromFile - file doesn't exist: C:\ProgramData\Mozilla\updates\B4A3EEF2ED7784F0\updates\0\bt.result
03:43:22 INFO - Console message: AUS:SVC readBinaryTransparencyResult - result: null, path: C:\ProgramData\Mozilla\updates\B4A3EEF2ED7784F0\updates\0\bt.result
03:43:22 INFO - Console message: AUS:SVC handleFallbackToCompleteUpdate - install of partial patch failed, downloading complete patch
03:43:22 INFO - Console message: AUS:SVC Creating Downloader
03:43:22 INFO - Console message: AUS:SVC UpdateService:_downloadUpdate
03:43:22 INFO - Console message: AUS:SVC readStringFromFile - file doesn't exist: C:\ProgramData\Mozilla\updates\B4A3EEF2ED7784F0\updates\0\update.status
03:43:22 INFO - Console message: AUS:SVC readStatusFile - status: null, path: C:\ProgramData\Mozilla\updates\B4A3EEF2ED7784F0\updates\0\update.status
03:43:22 INFO - Console message: AUS:SVC Downloader:_selectPatch - found existing patch with state: null
03:43:22 INFO - Console message: AUS:SVC Downloader:downloadUpdate - url: http://example.com/browser/toolkit/mozapps/update/tests/browser/simple.mar, path: C:\ProgramData\Mozilla\updates\B4A3EEF2ED7784F0\updates\0\update.mar, interval: 0
03:43:22 INFO - Console message: AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. topic: update-staged, status: downloading
03:43:22 INFO - Console message: AUS:SVC Downloader:onStartRequest - original URI spec: http://example.com/browser/toolkit/mozapps/update/tests/browser/simple.mar, final URI spec: http://example.com/browser/toolkit/mozapps/update/tests/browser/simple.mar
03:43:22 INFO - Console message: AUS:SVC Downloader:onProgress - progress: 1404/1404
03:43:22 INFO - Console message: AUS:SVC Downloader:onProgress - maxProgress: 1404 is not equal to expected patch size: 14041
03:43:22 INFO - Console message: AUS:SVC Downloader: cancel
03:43:22 INFO - Console message: AUS:SVC Downloader:onProgress - progress: 1404/1404
03:43:22 INFO - Console message: AUS:SVC Downloader:onProgress - maxProgress: 1404 is not equal to expected patch size: 14041
03:43:22 INFO - Console message: AUS:SVC Downloader: cancel
03:43:22 INFO - Console message: AUS:SVC Downloader:onStopRequest - original URI spec: http://example.com/browser/toolkit/mozapps/update/tests/browser/simple.mar, final URI spec: http://example.com/browser/toolkit/mozapps/update/tests/browser/simple.mar, status: 2147549183
03:43:22 INFO - Console message: AUS:SVC Downloader:onStopRequest - status: 2147549183, current fail: 0, max fail: 10, retryTimeout: 2000
03:43:22 INFO - Console message: AUS:SVC Downloader:onStopRequest - non-verification failure
03:43:22 INFO - Console message: AUS:SVC getStatusTextFromCode - transfer error: Failed (unknown reason), default code: 2152398849
03:43:22 INFO - Console message: AUS:SVC Downloader:onStopRequest - setting state to: download-failed
03:43:22 INFO - Console message: AUS:SVC Downloader:onStopRequest - notifying observers of error. topic: update-error, status: download-attempt-failed

overall I am not sure if we have updates on the normal server?

:rstrong, do you know if windows on arm64 has updates available?

Flags: needinfo?(robert.strong.bugs)
Summary: TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_aboutDialog_fc_downloadAuto_staging.js | Uncaught exception - Waiting for expected panel ID - got: "downloading", expected "apply" - timed out after 50 tries. → windows/aarch64 - toolkit/mozapps/update/tests/browser/browser_aboutDialog_fc_downloadAuto_staging.js | Uncaught exception - Waiting for expected panel ID - got: "downloading", expected "apply" - timed out after 50 tries.

We use in tree mar files and the test http server for tests. The problem is that they are compressed using xz --x86 which doesn't work with arm64 ( bug 1514124 ). I'll take care of this in the next few days.

Flags: needinfo?(robert.strong.bugs)

thanks :rstrong!

Depends on: 1514124

This doesn't actually depend on the releng bug 1514124. It just shows the same underlying issue which had to be fixed for the mar files we advertise to actual clients so removing dependency.

No longer depends on: 1514124
Posted patch patchSplinter Review
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED

Joel, if you have a chance please try out this patch on aarch64. Thanks!

Flags: needinfo?(jmaher)

Changed simple.mar from a complete mar to a partial mar to prevent it from accidentally removing application files via an application precomplete file.
Changed the name of the precomplete to update_precomplete in simple.mar so it won't accidentally replace an application's precomplete file.

Summary: windows/aarch64 - toolkit/mozapps/update/tests/browser/browser_aboutDialog_fc_downloadAuto_staging.js | Uncaught exception - Waiting for expected panel ID - got: "downloading", expected "apply" - timed out after 50 tries. → windows/aarch64 - Invalid test mar file - toolkit/mozapps/update/tests/browser/browser_aboutDialog_fc_downloadAuto_staging.js | Uncaught exception - Waiting for expected panel ID - got: "downloading", expected "apply" - timed out after 50 tries.

Joel, I triggered the xpcshell X8 tests (runs the app update xpcshell tests) and mochitest-chrome tests and as far as app update goes all is well. It appears that the system running the tests isn't setup 100% or the build system isn't authenticode signing the updater which is less likely to be the issue. A test was added for this since the app update tests were being incorrectly blamed for the build system.

00:29:49 INFO - TEST-START | toolkit/mozapps/update/tests/unit_service_updater/checkUpdaterSigSvc.js
00:29:49 WARNING - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/unit_service_updater/checkUpdaterSigSvc.js | xpcshell return code: 0

Here are a few of the related bugs
Bug 1203990
Bug 1353889
Bug 1067756

Duplicate of this bug: 1526430
Summary: windows/aarch64 - Invalid test mar file - toolkit/mozapps/update/tests/browser/browser_aboutDialog_fc_downloadAuto_staging.js | Uncaught exception - Waiting for expected panel ID - got: "downloading", expected "apply" - timed out after 50 tries. → windows/aarch64 - Invalid test mar file - toolkit/mozapps/update/tests/*

given the above bugs, should I be working on fixing the image we use for testing? I am unclear if there is more work I can do, or if we need to update the browser/installer/tests?

Flags: needinfo?(robert.strong.bugs)

I filed bug 1526982 for the work that needs to be performed.

Flags: needinfo?(robert.strong.bugs)
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5f4edb1fe66f
Compress files in the test mar files without specifying --x86 so the test mar files will work with aarch64. r=mhowell
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

if we look at all updater tests, the xpcshell tests still fail.

(In reply to Joel Maher ( :jmaher ) (UTC-4) from comment #18)

if we look at all updater tests, the xpcshell tests still fail.
Can you provide a link? Those failures could very well be due to bug 1526982

It looks like the only failure is the one mentioned in comment #10 which is due to bug 1526982

You need to log in before you can comment on or make changes to this bug.