UI elements become unclickable after tab reordering with new tab animations

RESOLVED DUPLICATE of bug 1539255

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1539255
4 months ago
2 months ago

People

(Reporter: asa, Assigned: Felipe)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 months ago

I don't have a lot to go on here. Sorry.

Testing today's nightly build on x86 on Windows 10 occasionally some UI elements, an extension button, the tab close x button, etc. become unclickable. They don't have a hover state and clicking them does nothing. Restarting Firefox fixes things, at least for a while, then I find something I can't click on again.

I often see "A web page is slowing down your browser. What would you like to do?" message, and I am on Linux.

Did you enable the new tab animations by any chance?

(In reply to Hiroyuki Ikezoe (:hiro) from comment #1)

I often see "A web page is slowing down your browser. What would you like to do?" message, and I am on Linux.

This message appears when the parent process detects that the content process for a tab is spending lots of time stuck in JS. I suspect that this is a separate issue from what Asa is experiencing. If you want to diagnose it, your best bet is probably to run the profiler, recreate the issue, wait a few seconds, and then click on the "Stop it" button in the notification bar, and then dump the profile immediately.

(In reply to Asa Dotzler [:asa] from comment #0)

Testing today's nightly build on x86 on Windows 10 occasionally some UI elements, an extension button, the tab close x button, etc. become unclickable. They don't have a hover state and clicking them does nothing. Restarting Firefox fixes things, at least for a while, then I find something I can't click on again.

Is the parent process hung, or is it just not responding to mouse events? Can you, for example, use Ctrl-L to focus the URL bar in this state?

Flags: needinfo?(asa)

(In reply to Mike Conley (:mconley) (:⚙️) from comment #3)

Is the parent process hung, or is it just not responding to mouse events? Can you, for example, use Ctrl-L to focus the URL bar in this state?

In my case, it doesn't look like the process is hanging, as not all the elements are unclickable. For example, I can still switch between tabs, but I can't close them.

(In reply to Marco Castelluccio [:marco] from comment #4)

In my case, it doesn't look like the process is hanging, as not all the elements are unclickable. For example, I can still switch between tabs, but I can't close them.

When you attempt and fail to switch between tabs, does anything appear in the browser console?

(In reply to Mike Conley (:mconley) (:⚙️) from comment #5)

(In reply to Marco Castelluccio [:marco] from comment #4)

In my case, it doesn't look like the process is hanging, as not all the elements are unclickable. For example, I can still switch between tabs, but I can't close them.

When you attempt and fail to switch between tabs, does anything appear in the browser console?

Nothing.

Disabling browser.tabs.newanimations appears to fix the problem for me.

(In reply to Marco Castelluccio [:marco] from comment #6)

Nothing.

Disabling browser.tabs.newanimations appears to fix the problem for me.

Interesting. Hey felipe, any idea what's going on here?

Blocks: 1355588
Flags: needinfo?(felipc)
Component: Untriaged → Theme

(Hey Asa, I'm assuming at this point that what you're experiencing is the same thing that marco is experiencing... if it sounds different enough, we can spin marco's bug out separately)

For people who have toggle browser.tabs.newanimations to true, yeah I've seen that bug happened after reordering tabs by dragging.. I'll look into that more. It's some transitionend state that is not being adjusted correctly.

I think anything about the browser becoming unresponsive is probably unrelated to this.

Assignee: nobody → felipc
Blocks: 1522191
Status: NEW → ASSIGNED
Flags: needinfo?(felipc)
Summary: UI elements become unclickable → UI elements become unclickable after tab reordering with new tab animations
Priority: -- → P3
Reporter

Comment 10

4 months ago

Yes! I enabled the new tab animation. That's it. I was struggling to identify STR for this one. Thanks for figuring it out!

Flags: needinfo?(asa)

Let me know if you need help with this. We implemented transitioncancel precisely because sometimes transitionend is not dispatched and that was breaking some Firefox OS apps occasionally. Alternatively, you might try using elem.getAnimations(), find the appropriate transition, and then wait on its finished promise (which will reject if the transition is canceled).

Duplicate of this bug: 1531270

Updated

3 months ago
Duplicate of this bug: 1533266

Comment 14

3 months ago

I experienced the same bug. It indeed happens when I reorder the tabs, keyboard shortcuts like Ctrl+L still work but I cannot click the close button or any button in the navigationbar.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1539255
You need to log in before you can comment on or make changes to this bug.