Closed Bug 1526477 Opened 7 months ago Closed 7 months ago

Firefox failing to nominate ICE pairs when interoping with an ice-lite endpoint

Categories

(Core :: WebRTC: Networking, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox65 --- wontfix
firefox66 --- fixed
firefox67 --- fixed

People

(Reporter: bwc, Assigned: bwc)

References

Details

Attachments

(2 files)

Observed over in bug 1525802. Maybe we're trying to do regular nomination, but failing?

See Also: → 1525802
Blocks: 1525802

Yeah, we're definitely getting confused on an ICE restart with ice-lite, and thinking we're in the controlled role.

Assignee: nobody → docfaraday
Priority: -- → P2

Ugh. Looks like the try push never actually made it into CI somehow.

Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/07d21448117d
Part 0: Test role for ice-lite cases. r=mjf
https://hg.mozilla.org/integration/autoland/rev/40fbc56a0763
Part 1: Fix typo causing us to go into the controlled role when interoping with an ice-lite endpoint. r=mjf
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Duplicate of this bug: 1528970

Byron, can request uplift of this (looks like an easy fix)?

Flags: needinfo?(docfaraday)

Comment on attachment 9042658 [details]
Bug 1526477 - Part 1: Fix typo causing us to go into the controlled role when interoping with an ice-lite endpoint.

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1486012
  • User impact if declined: Some webrtc services will break.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Extremely low risk; just changing the value of a bool (this bool regularly takes both possible values).
  • String changes made/needed: None.
Flags: needinfo?(docfaraday)
Attachment #9042658 - Flags: approval-mozilla-beta?

Comment on attachment 9042658 [details]
Bug 1526477 - Part 1: Fix typo causing us to go into the controlled role when interoping with an ice-lite endpoint.

Typo fix for regression from 64.
OK for uplift for beta 13.

Attachment #9042658 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1525802

(In reply to Byron Campen [:bwc] from comment #12)

  • Is this code covered by automated tests?: Yes
  • Needs manual test from QE?: No

Setting qe-verify flag to [-] per comment 12.

Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.