Closed Bug 1526656 Opened 11 months ago Closed 10 months ago

Crash in [@ mozilla::gfx::DrawTargetD2D1::GetImageForSurface]

Categories

(Core :: Graphics, defect, P1, critical)

66 Branch
All
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1524554
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 + fixed
firefox67 --- fixed

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-f46302d9-f428-4ccc-bdb1-aea150190209.

Top 8 frames of crashing thread:

0 xul.dll mozilla::gfx::DrawTargetD2D1::GetImageForSurface gfx/2d/DrawTargetD2D1.cpp:2111
1 xul.dll mozilla::gfx::DrawTargetD2D1::DrawSurfaceWithShadow gfx/2d/DrawTargetD2D1.cpp:297
2 xul.dll void mozilla::dom::AdjustedTargetForShadow::~AdjustedTargetForShadow dom/canvas/CanvasRenderingContext2D.cpp:504
3 xul.dll void mozilla::UniquePtr<mozilla::dom::AdjustedTargetForShadow, mozilla::DefaultDelete<mozilla::dom::AdjustedTargetForShadow> >::reset mfbt/UniquePtr.h:323
4 xul.dll void mozilla::dom::AdjustedTarget::~AdjustedTarget dom/canvas/CanvasRenderingContext2D.cpp:612
5 xul.dll mozilla::dom::CanvasRenderingContext2D::DrawImage dom/canvas/CanvasRenderingContext2D.cpp:4791
6 xul.dll static bool mozilla::dom::CanvasRenderingContext2D_Binding::drawImage dom/bindings/CanvasRenderingContext2DBinding.cpp
7  @0x2596835a 

this crash signature has been existing for a long time but these tab crashes are regressing in volume in the 66.0b cycle. during 66 nightly it first appeared in build 20190120213632, so timing-wise this might point towards bug 1519760 as the regressor.

Thoughts Bas?

Flags: needinfo?(bas)
Priority: -- → P1

This is a regression on device resets from indeed bug 1619760. Seems to be very low volume though, but I should look into fixing it.

Flags: needinfo?(bas)

Hey Bas - are you going to look into this?

Flags: needinfo?(bas)

Yes, these are the issues fixed in bug 1524554.

Flags: needinfo?(bas)
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1524554
You need to log in before you can comment on or make changes to this bug.