Closed Bug 1527055 Opened 1 year ago Closed 2 months ago

Intermittent dom/events/test/test_bug574663.html | unexpected-crash-dump-found - This test left crash dumps behind, but we weren't expecting it to!

Categories

(Core :: Graphics: Layers, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1523853
Tracking Status
firefox-esr68 --- disabled
firefox69 --- disabled

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell disabled])

Attachments

(2 files)

#[markdown(off)]
Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=227658627&repo=autoland

https://queue.taskcluster.net/v1/task/TiZZoMPUQ9eUp7u7J05bOA/runs/0/artifacts/public/logs/live_backing.log

16:21:48 INFO - GECKO(11132) | ###!!! [Child][MessageChannel] Error: (msgtype=0x920003,name=PTexture::Msg_Destroy) Channel error: cannot send/recv
16:21:48 INFO - GECKO(11132) | ###!!! [Child][MessageChannel] Error: (msgtype=0x580005,name=PLayerTransaction::Msg_ReleaseLayer) Channel error: cannot send/recv
16:21:48 INFO - GECKO(11132) | ###!!! [Child][MessageChannel] Error: (msgtype=0x58001E,name=PLayerTransaction::Msg_Shutdown) Channel error: cannot send/recv
16:21:48 INFO - GECKO(11132) | ###!!! [Child][MessageChannel] Error: (msgtype=0x920003,name=PTexture::Msg_Destroy) Channel error: cannot send/recv
16:21:48 INFO - GECKO(11132) | ###!!! [Child][MessageChannel::SendAndWait] Error: (msgtype=0x310017,name=PCompositorBridge::Msg_WillClose) Channel error: cannot send/recv
16:21:48 INFO - GECKO(11132) | [GFX1-]: Receive IPC close with reason=AbnormalShutdown
16:21:48 INFO - GECKO(11132) | [GFX1-]: Receive IPC close with reason=AbnormalShutdown
16:21:48 INFO - Buffered messages logged at 16:21:47
16:21:48 INFO - must wait for load
16:21:48 INFO - must wait for focus
16:21:48 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Normal scrolling shouldn't change zoom
16:21:48 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Normal scrolling should scroll
16:21:48 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Normal scrolling shouldn't change zoom, even after releasing the touchpad
16:21:48 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Normal scrolling should scroll, even after releasing the touchpad
16:21:48 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Ctrl-scrolling should zoom while the user is touching the touchpad
16:21:48 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Ctrl-scrolling shouldn't scroll while the user is touching the touchpad
16:21:48 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Momentum scrolling shouldn't zoom, even when pressing Ctrl
16:21:48 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Momentum scrolling should scroll, even when pressing Ctrl
16:21:48 INFO - Buffered messages finished
16:21:48 INFO - TEST-UNEXPECTED-ERROR | dom/events/test/test_bug574663.html | unexpected-crash-dump-found - This test left crash dumps behind, but we weren't expecting it to!
16:21:48 INFO - Found unexpected crash dump file C:\Users\task_1549900893\AppData\Local\Temp\tmpragr5c.mozrunner\minidumps\579566c2-6578-4574-b448-f30bd00b10b0.dmp.
16:21:48 INFO - Found unexpected crash dump file C:\Users\task_1549900893\AppData\Local\Temp\tmpragr5c.mozrunner\minidumps\579566c2-6578-4574-b448-f30bd00b10b0.extra.
16:21:48 INFO - GECKO(11132) | ###!!! [Child][MessageChannel] Error: (msgtype=0x580001,name=PLayerTransaction::Msg_Update) Channel error: cannot send/recv
16:21:48 INFO - GECKO(11132) | [GFX1-]: Receive IPC close with reason=AbnormalShutdown
16:21:48 INFO - TEST-UNEXPECTED-CRASH | dom/events/test/test_bug574663.html | Finished in 791ms
16:21:48 INFO - {u'runtime': 791}
16:21:48 INFO - TEST-INFO took 791ms

Duplicate of this bug: 1527072

All failure on Windows 10 and started yesterday - fallout from bug 1522896?

Flags: needinfo?(jmaher)

I would argue this is related to the windows10 version update- lets see the failure pattern and see if we need to debug it more or skip it on opt or debug for win10.

Flags: needinfo?(jmaher)

This bug failed 42 times in the last 7 days. Occurs on windows10-64 on debug, opt and pgo.

Recent log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=229339062&repo=autoland&lineNumber=33250

hsinyi:
Can you please take a look at this bug?

Flags: needinfo?(htsai)
Whiteboard: [stockwell needswork:owner] → [stockwell needswork:owner][stockwell needswork]

Olli did some improvement for this test in bug 1523158. He may have ideas here, too.

Flags: needinfo?(htsai) → needinfo?(bugs)
See Also: → 1523158

There have been 37 failures within the last 7 days, all of them on Windows 10 x64 - mostly pgo - with 5 occurences on opt and 1 on debug.
Recent log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=231581233&repo=autoland&lineNumber=8542

This bug has failed 42 times in the last 7 days, Occurs on windwos10-64 on pgo and opt build types.

Recent log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=233254358&repo=mozilla-inbound&lineNumber=8124

Opettay: did you have a chance to look at this bug?

I'll try to find time.

There are 45 failures associated to this bug in the last 7 days. These are occurring on windows10-64 pgo.

There are 26 total failures in the last 7 days on windows10-64, windows10-64-shippable both opt

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=238522361&repo=mozilla-central&lineNumber=8465

23:12:53 INFO - TEST-START | dom/events/test/test_bug574663.html
23:12:53 INFO - GECKO(3660) | JavaScript warning: chrome://global/content/bindings/tabbox.xml, line 162: Array.forEach is deprecated; use Array.prototype.forEach instead
23:12:53 INFO - GECKO(3660) | JavaScript warning: chrome://browser/content/browser-ctrlTab.js, line 568: Array.filter is deprecated; use Array.prototype.filter instead

23:12:54 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Ctrl-scrolling shouldn't scroll while the user is touching the touchpad
23:12:54 INFO - Buffered messages logged at 23:12:54
23:12:54 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Momentum scrolling shouldn't zoom, even when pressing Ctrl
23:12:54 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Momentum scrolling should scroll, even when pressing Ctrl
23:12:54 INFO - Buffered messages finished
23:12:54 INFO - TEST-UNEXPECTED-ERROR | dom/events/test/test_bug574663.html | unexpected-crash-dump-found - This test left crash dumps behind, but we weren't expecting it to!
23:12:54 INFO - Found unexpected crash dump file C:\Users\task_1554504051\AppData\Local\Temp\tmpkz1tmh.mozrunner\minidumps\f5a6cc60-817d-45c3-81e2-0d5099b6500f.dmp.
23:12:54 INFO - Found unexpected crash dump file C:\Users\task_1554504051\AppData\Local\Temp\tmpkz1tmh.mozrunner\minidumps\f5a6cc60-817d-45c3-81e2-0d5099b6500f.extra.
23:12:54 INFO - GECKO(3660) | [GFX1-]: Receive IPC close with reason=AbnormalShutdown
23:12:54 INFO - TEST-UNEXPECTED-CRASH | dom/events/test/test_bug574663.html | Finished in 740ms
23:12:54 INFO - {u'runtime': 740}
23:12:54 INFO - TEST-INFO took 740ms

olli are there updates here?

Flags: needinfo?(bugs)
Flags: needinfo?(bugs)
Whiteboard: [stockwell needswork:owner][stockwell needswork] → [stockwell needswork:owner]

This has 40 failures in the last 7 days, all are on windows 10 opt & debug: https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-04-12&endday=2019-04-19&tree=trunk&bug=1527055

Hsin-Yi Tsai, could you please redirect this to someone who can take a look? Olli doesn't seem to have any progress on this.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=240649347&repo=autoland&lineNumber=35402

Flags: needinfo?(htsai)

(In reply to Cosmin Sabou [:CosminS] from comment #20)

This has 40 failures in the last 7 days, all are on windows 10 opt & debug: https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-04-12&endday=2019-04-19&tree=trunk&bug=1527055

Hsin-Yi Tsai, could you please redirect this to someone who can take a look? Olli doesn't seem to have any progress on this.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=240649347&repo=autoland&lineNumber=35402

Sorry for being late here. I'll work with Olli to put into his plan while I'm exploring alternatives. Thank you.

Flags: needinfo?(htsai)
Priority: -- → P2

In the last 7 days, there have been 31 failures.

The failures are on windows10-64-shippable and windows10-64 platforms, opt build types.

An example of a recent log file:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=245271235&repo=mozilla-central&lineNumber=8167

And the relevant part of the log:
05:17:02 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Momentum scrolling should scroll, even when pressing Ctrl
05:17:02 INFO - Buffered messages finished
05:17:02 INFO - TEST-UNEXPECTED-ERROR | dom/events/test/test_bug574663.html | unexpected-crash-dump-found - This test left crash dumps behind, but we weren't expecting it to!
05:17:02 INFO - Found unexpected crash dump file C:\Users\task_1557291422\AppData\Local\Temp\tmpitycyo.mozrunner\minidumps\b98328d8-3679-4a67-8600-2d050dad1520.dmp.
05:17:02 INFO - Found unexpected crash dump file C:\Users\task_1557291422\AppData\Local\Temp\tmpitycyo.mozrunner\minidumps\b98328d8-3679-4a67-8600-2d050dad1520.extra.
05:17:02 INFO - GECKO(1844) | ###!!! [Child][MessageChannel] Error: (msgtype=0x580001,name=PLayerTransaction::Msg_Update) Channel error: cannot send/recv
05:17:02 INFO - GECKO(1844) | [GFX1-]: Receive IPC close with reason=AbnormalShutdown
05:17:02 INFO - TEST-UNEXPECTED-CRASH | dom/events/test/test_bug574663.html | Finished in 962ms

:hsinyi As you are the triage owner of this component, could you please take a look at this?
Thank you!

Flags: needinfo?(htsai)

(In reply to Cristina Coroiu [:ccoroiu] from comment #25)

In the last 7 days, there have been 31 failures.

The failures are on windows10-64-shippable and windows10-64 platforms, opt build types.

An example of a recent log file:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=245271235&repo=mozilla-central&lineNumber=8167

And the relevant part of the log:
05:17:02 INFO - TEST-PASS | dom/events/test/test_bug574663.html | Momentum scrolling should scroll, even when pressing Ctrl
05:17:02 INFO - Buffered messages finished
05:17:02 INFO - TEST-UNEXPECTED-ERROR | dom/events/test/test_bug574663.html | unexpected-crash-dump-found - This test left crash dumps behind, but we weren't expecting it to!
05:17:02 INFO - Found unexpected crash dump file C:\Users\task_1557291422\AppData\Local\Temp\tmpitycyo.mozrunner\minidumps\b98328d8-3679-4a67-8600-2d050dad1520.dmp.
05:17:02 INFO - Found unexpected crash dump file C:\Users\task_1557291422\AppData\Local\Temp\tmpitycyo.mozrunner\minidumps\b98328d8-3679-4a67-8600-2d050dad1520.extra.
05:17:02 INFO - GECKO(1844) | ###!!! [Child][MessageChannel] Error: (msgtype=0x580001,name=PLayerTransaction::Msg_Update) Channel error: cannot send/recv
05:17:02 INFO - GECKO(1844) | [GFX1-]: Receive IPC close with reason=AbnormalShutdown
05:17:02 INFO - TEST-UNEXPECTED-CRASH | dom/events/test/test_bug574663.html | Finished in 962ms

:hsinyi As you are the triage owner of this component, could you please take a look at this?
Thank you!

Olli is resuming the work here. Thanks, Olli!

Flags: needinfo?(htsai)

ah, looks like the failures are coming from bug test_bug556493.html

Component: DOM: Events → Graphics: Layers
Flags: needinfo?(bugs)

FWIW, this is waiting for the generic IPC layer cleanup/fix, which Nika told in dev-platform.

Whiteboard: [stockwell disable-recommended]

Over the last 7 days there are 136 failures occurring on this bug. These happen on windows10-64 and windows10-64-shippable.

Here is the most recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=249096933&repo=autoland&lineNumber=7902

Flags: needinfo?(jbonisteel)

Nika, do you know when the generic IPC layer cleanup/fix Olli mentions will land? Is there another bug tracking that cleanup?

Flags: needinfo?(jbonisteel) → needinfo?(nika)
Whiteboard: [stockwell disable-recommended]

Those patches have landed in bug 1540731

Flags: needinfo?(nika)
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b51ad1728a4c
disabled test_bug574663.html on win not debug r=jmaher
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee: nobody → apavel
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---

Looks like we want to just disable this on Windows across the board.

Flags: needinfo?(apavel)
Flags: needinfo?(apavel)
Pushed by rvandermeulen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e62567bd44f
disabled test_bug574663.html on win r=RyanVM
Status: REOPENED → NEW
Target Milestone: mozilla69 → ---
Assignee: apavel → nobody

General fixes for this test are happening in Bug 1523853, which will also re-enable it for Windows.

Status: NEW → RESOLVED
Closed: 10 months ago2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1523853
You need to log in before you can comment on or make changes to this bug.