Disable dynamic reflow roots in Firefox 66 (beta/release)

RESOLVED FIXED

Status

()

defect
P1
normal
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: dholbert, Assigned: dholbert)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 unaffected, firefox66 fixed, firefox67 unaffected)

Details

Attachments

(1 attachment)

Bug 1510360 makes the "dynamic reflow root" optimization produce invalid layout in some edge cases (and that's bad, because this feature isn't supposed to have any detectable effect besides improving performance).

I'm hoping to have some time to fix bug 1510360 for this Nightly 67 cycle, but I'm not 100% sure that I'll have a patch ready in time for "comfortable" beta uplift timing.

I think we should just pref off dynamic reflow roots on beta/release for the Firefox 66 cycle; they'd probably benefit from a bit more testing, anyway.

Depends on: 1159042
Summary: Disable dynamic reflow roots in beta → Disable dynamic reflow roots in Firefox 66 (beta/release)

Comment on attachment 9043133 [details]
Bug 1527120: Disable "dynamic reflow root" feature on beta, due to having at least one unresolved regression. r?dbaron

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1159042

User impact if declined

Broken layout, in pages where the optimization takes effect & where bug 1510360 rears its head

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

This change is just preffing off a recently-added opportunistic optimization (one which is probably activated infrequently, in the real world), because it's known to break layout in some cases. The optimization was only added in the Firefox 66 timeframe (bug 1159042) so that's where I'd like to pref it off.

(I'm leaving it on in Nightly because the known regression isn't too bad and I'm hoping to fix it soon; but for Beta we might as well just pref it off.)

String changes made/needed

None.

Attachment #9043133 - Flags: approval-mozilla-beta?

Comment on attachment 9043133 [details]
Bug 1527120: Disable "dynamic reflow root" feature on beta, due to having at least one unresolved regression. r?dbaron

Disable a feature for 66. OK to uplift for beta 9.

Attachment #9043133 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Thanks!

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Blocks: 1547852
You need to log in before you can comment on or make changes to this bug.