Disable dynamic reflow roots after early-beta

RESOLVED FIXED in Firefox 67

Status

()

defect
P2
normal
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: dholbert, Assigned: dholbert)

Tracking

(Blocks 1 bug)

Trunk
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 disabled, firefox67+ fixed, firefox68 fixed)

Details

Attachments

(1 attachment)

As noted in bug 1527120 comment 0, we have some known regressions that are caused by Dynamic Reflow Roots -- and bug 1547305 seems to be a newly-discovered regression that it causes.

In bug 1527120, I did a "spot fix" for Firefox 66 to pref off the feature, with the hope of addressing the regressions before 67. But that didn't happen -- and until we've got time to address these regressions, we should guard Dynamic Reflow Roots from making it to release.

I think a "don't ship past early-beta" guard should be appropriate -- we can keep it enabled in "early builds", since the regressions aren't catastrophic and the feature is only activated in rare specific cases (I think). And there's value to keeping it enabled for these early builds, since it helps us keep it working & discover potential unknown breakage.

(Also: fortunately, this isn't a feature that's visible to users or web developers, really, so we can disable it without anyone really noticing.)

Blocks: 1547859
Depends on: 1159042

[Tracking Requested - why for this release]:
I think we shouldn't let this feature (Dynamic Reflow Roots) hit release quite yet, so I'm requesting tracking for v67 to be sure we get this pref-it-off patch uplifted to 67 beta before that version becomes release.

Pushed by dholbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/acac503a7361
Only enable dynamic reflow roots up through early beta. r=dbaron

Comment on attachment 9061531 [details]
Bug 1547852: Only enable dynamic reflow roots up through early beta. r?dbaron

Beta/Release Uplift Approval Request

  • User impact if declined: Broken layout, in pages where the optimization takes effect & where one of the known regressions happen to be triggered.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This change is just preffing off a recently-added opportunistic optimization (one which is probably activated infrequently, in the real world), because it's known to break layout in some cases. The optimization was only added in the Firefox 66 timeframe (bug 1159042), and we preffed it off in that release via bug 1527120, and this bug is just making that pref-off into a persistent thing.
    (I'm leaving it preffed on in Nightly and early-beta because the known regressions aren't too bad.)
  • String changes made/needed: None
Attachment #9061531 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Comment on attachment 9061531 [details]
Bug 1547852: Only enable dynamic reflow roots up through early beta. r?dbaron

Uplift accepted for 67 beta 16, thanks.

Attachment #9061531 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.