Closed Bug 1527227 Opened 8 months ago Closed 8 months ago

Infra ERROR: Rust compiler 1.31.0-nightly is too old. | make: *** [configure] Error 1

Categories

(Firefox Build System :: General, defect, P5)

defect

Tracking

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67 fixed)

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: marco)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 obsolete file)

#[markdown(off)]
Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=227839017&repo=mozilla-central

https://queue.taskcluster.net/v1/task/DRrPdyG_RcehqNJ6yJRdbQ/runs/0/artifacts/public/logs/live_backing.log

[task 2019-02-12T05:33:29.336Z] 05:33:29 INFO - checking whether the C++ compiler supports -Wformat-overflow=2... no
[task 2019-02-12T05:33:29.493Z] 05:33:29 INFO - checking whether the C compiler supports -Wno-gnu-zero-variadic-macro-arguments... no
[task 2019-02-12T05:33:29.654Z] 05:33:29 INFO - checking whether the C++ compiler supports -Wno-gnu-zero-variadic-macro-arguments... no
[task 2019-02-12T05:33:29.816Z] 05:33:29 INFO - checking whether the C++ compiler supports -fno-sized-deallocation... yes
[task 2019-02-12T05:33:29.823Z] 05:33:29 INFO - checking for libpulse... yes
[task 2019-02-12T05:33:29.965Z] 05:33:29 INFO - checking MOZ_PULSEAUDIO_CFLAGS... -D_REENTRANT
[task 2019-02-12T05:33:30.107Z] 05:33:30 INFO - checking MOZ_PULSEAUDIO_LIBS... -lpulse
[task 2019-02-12T05:33:30.108Z] 05:33:30 INFO - checking for cbindgen... /builds/worker/workspace/build/src/cbindgen/cbindgen
[task 2019-02-12T05:33:30.251Z] 05:33:30 INFO - checking cbindgen version... 0.7.1
[task 2019-02-12T05:33:30.252Z] 05:33:30 INFO - checking for rustfmt... /builds/worker/workspace/build/src/rustc/bin/rustfmt
[task 2019-02-12T05:33:30.252Z] 05:33:30 INFO - checking for llvm-config... /builds/worker/workspace/build/src/clang/bin/llvm-config
[task 2019-02-12T05:33:30.860Z] 05:33:30 INFO - checking bindgen cflags... -x c++ -fno-sized-deallocation -DTRACING=1 -DIMPL_LIBXUL -DMOZILLA_INTERNAL_API -DRUST_BINDGEN -DOS_POSIX=1 -DOS_LINUX=1
[task 2019-02-12T05:33:30.862Z] 05:33:30 INFO - checking for rustc... /builds/worker/workspace/build/src/rustc/bin/rustc
[task 2019-02-12T05:33:30.862Z] 05:33:30 INFO - checking for cargo... /builds/worker/workspace/build/src/rustc/bin/cargo
[task 2019-02-12T05:33:31.039Z] 05:33:31 INFO - checking rustc version... 1.31.0-nightly
[task 2019-02-12T05:33:31.196Z] 05:33:31 INFO - checking cargo version... 1.31.0
[task 2019-02-12T05:33:31.196Z] 05:33:31 INFO - ERROR: Rust compiler 1.31.0-nightly is too old.
[task 2019-02-12T05:33:31.196Z] 05:33:31 INFO - To compile Rust language sources please install at least
[task 2019-02-12T05:33:31.196Z] 05:33:31 INFO - version 1.32.0 of the 'rustc' toolchain and make sure it is
[task 2019-02-12T05:33:31.196Z] 05:33:31 INFO - first in your path.
[task 2019-02-12T05:33:31.196Z] 05:33:31 INFO - You can verify this by typing 'rustc --version'.
[task 2019-02-12T05:33:31.197Z] 05:33:31 INFO - If you have the 'rustup' tool installed you can upgrade
[task 2019-02-12T05:33:31.197Z] 05:33:31 INFO - to the latest release by typing 'rustup update'. The
[task 2019-02-12T05:33:31.197Z] 05:33:31 INFO - installer is available from https://rustup.rs/
[task 2019-02-12T05:33:31.233Z] 05:33:31 INFO - *** Fix above errors and then restart with\
[task 2019-02-12T05:33:31.233Z] 05:33:31 INFO - "./mach build"
[task 2019-02-12T05:33:31.233Z] 05:33:31 INFO - client.mk:111: recipe for target 'configure' failed
[task 2019-02-12T05:33:31.233Z] 05:33:31 INFO - make: *** [configure] Error 1
[task 2019-02-12T05:33:31.345Z] 05:33:31 ERROR - Return code: 2
[task 2019-02-12T05:33:31.345Z] 05:33:31 WARNING - setting return code to 2
[task 2019-02-12T05:33:31.345Z] 05:33:31 FATAL - 'mach build -v' did not run successfully. Please check log for errors.
[task 2019-02-12T05:33:31.345Z] 05:33:31 FATAL - Running post_fatal callback...
[task 2019-02-12T05:33:31.345Z] 05:33:31 FATAL - Exiting -1
[task 2019-02-12T05:33:31.346Z] 05:33:31 INFO - [mozharness: 2019-02-12 05:33:31.345951Z] Finished build step (failed)
[task 2019-02-12T05:33:31.346Z] 05:33:31 INFO - Running post-run listener: _parse_build_tests_ccov
[task 2019-02-12T05:33:31.346Z] 05:33:31 INFO - Running post-run listener: _shutdown_sccache
[task 2019-02-12T05:33:31.346Z] 05:33:31 INFO - Running command: ['/builds/worker/workspace/build/src/sccache2/sccache', '--stop-server'] in /builds/worker/workspace/build/src
[task 2019-02-12T05:33:31.346Z] 05:33:31 INFO - Copy/paste: /builds/worker/workspace/build/src/sccache2/sccache --stop-server
[task 2019-02-12T05:33:31.350Z] 05:33:31 INFO - Stopping sccache server...
[task 2019-02-12T05:33:31.351Z] 05:33:31 INFO - error: couldn't connect to server
[task 2019-02-12T05:33:31.351Z] 05:33:31 INFO - caused by: Connection refused (os error 111)
[task 2019-02-12T05:33:31.351Z] 05:33:31 ERROR - Return code: 2
[task 2019-02-12T05:33:31.351Z] 05:33:31 INFO - Running post-run listener: _summarize
[task 2019-02-12T05:33:31.351Z] 05:33:31 ERROR - # TBPL FAILURE #
[task 2019-02-12T05:33:31.351Z] 05:33:31 INFO - [mozharness: 2019-02-12 05:33:31.351791Z] FxDesktopBuild summary:
[task 2019-02-12T05:33:31.352Z] 05:33:31 ERROR - # TBPL FAILURE #
[task 2019-02-12T05:33:31.359Z] cleanup
[task 2019-02-12T05:33:31.359Z] + cleanup
[task 2019-02-12T05:33:31.359Z] + local rv=255
[task 2019-02-12T05:33:31.359Z] + cleanup_xvfb
[task 2019-02-12T05:33:31.359Z] pidof Xvfb
[task 2019-02-12T05:33:31.359Z] ++ pidof Xvfb
[task 2019-02-12T05:33:31.360Z] + local xvfb_pid=34
[task 2019-02-12T05:33:31.360Z] + local vnc=false
[task 2019-02-12T05:33:31.361Z] + local interactive=false
[task 2019-02-12T05:33:31.361Z] + '[' -n 34 ']'
[task 2019-02-12T05:33:31.361Z] + [[ false == false ]]
[task 2019-02-12T05:33:31.361Z] + [[ false == false ]]
[task 2019-02-12T05:33:31.361Z] + kill 34
[task 2019-02-12T05:33:31.361Z] + screen -XS xvfb quit
[task 2019-02-12T05:33:31.504Z] No screen session found.
[task 2019-02-12T05:33:31.504Z] + true
[task 2019-02-12T05:33:31.504Z] + exit 255
[taskcluster 2019-02-12 05:33:32.501Z] === Task Finished ===
[taskcluster 2019-02-12 05:33:37.682Z] Unsuccessful task run with exit code: 255 completed in 130.121 seconds

Summary: Intermittent make: *** [configure] Error 1 → Infra ERROR: Rust compiler 1.31.0-nightly is too old. | make: *** [configure] Error 1
See Also: → 1525733
Flags: needinfo?(cmanchester)

Our required rustc version now exceeds the nightly we're using for these jobs. Unfortunately I missed this because -p all doesn't run them on try.

Marco, can you please update these jobs to use the current rustc or an appropriately recent nightly?

Blocks: 1525733
Flags: needinfo?(cmanchester) → needinfo?(mcastelluccio)
See Also: 1525733
Assignee: nobody → mcastelluccio
Status: NEW → ASSIGNED
Flags: needinfo?(mcastelluccio)
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/76639dcdef8f
Update Rust nightly version. r=chmanchester a=Aryx
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Attachment #9043264 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.