Closed Bug 1527459 Opened 2 years ago Closed 2 years ago

Display dependency bugs by type, using the same colour/icon for each

Categories

(bugzilla.mozilla.org :: User Interface, enhancement)

Production
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: kohei.yoshino, Assigned: kohei.yoshino)

References

Details

Attachments

(2 files, 2 obsolete files)

Attached image quick mockup (obsolete) —

An idea by Sylvestre: Use the new bug type colour coding (red/green/blue) for the bug list on the Depends on and Blocked fields. See the attached quick mockup. It can actually be used everywhere.

By the way, as :philipp mentioned on IRC, red and green look similar for people with colour blindness. The label on the bug header is fine (I’ll tweak the green colour as per his feedback anyway) but small dots like my mockup posted above will be a problem. These indicators should come with distinguishable icons like Jira. (We are coincidentally using the same red/green/blue coding)

See Also: → 1531481
Attached image quick mockup v2 (obsolete) —

An idea brought by Sylvestre: bug list fields including Depends on could be categorized by type like this mockup. This is particularly useful on meta bugs having a bunch of blockers like Bug 635134.

Attachment #9043413 - Attachment is obsolete: true
See Also: → 1534762
Attached image quick mockup v3
Attachment #9050412 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Duplicate of this bug: 1540307

This will be done after Bug 1344091.

Depends on: 1344091

This goes first, followed by Bug 1344091.

No longer depends on: 1344091
Summary: Apply bug type colour coding to dependency fields and elsewhere → Display dependency bugs by type, using the same colour/icon for each
Attached file GitHub Pull Request

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.