Status

defect
RESOLVED DUPLICATE of bug 1494764
2 months ago
2 months ago

People

(Reporter: emoore, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 months ago

Several Thunderbird 60.5 users had reported in http://forums.mozillazine.org/viewtopic.php?f=39&t=3046991&p=14824029 that a ')' character or a string such as --000_1297a61c79664c73946928e037ecaccaz--) was being appended to the end of messages. This problem didn't occur when reading the same message in webmail or non-Mozilla email clients.

I was able to duplicate the problem. It appears that in certain IMAP accounts a ')' character is appended to the boundary string at the end of the last MIME section. This causes the corrupted boundary string to be displayed. It should have displayed only the contents of the message body.

I sent a test abc message using Gmail webmail to my Fastmail IMAP account using Thunderbird 60.5 under Windows 10. The message I received in my Fastmail IMAP account is okay, but the copy in my Gmail IMAP account is wrong. I see test abc
--0000000000005c67120581c77a4c--) instead of test abc. The original in Gmail webmail is fine. The raw message source in Gmail webmail is also fine.

If I switch from View -> Message body as -> Original HTML to Plain text the Gmail message looks fine since the boundary string as the end of the HTML MIME section (the last MIME section) is whats corrupted.

I have versions 52.9.1, 60.5 and 66.0b1 installed, sharing the same profile. If I switch from 60.5 to 52.9.1 the problem goes away. It returns if I switch to 66.0b1. I also verified the problem occurs in 60.5 if I run Thunderbird in safe mode.

I did not test whether the problem occurs in POP accounts.

FASTMAIL IMAP:
Content-Type: multipart/alternative; boundary="000000000000fad4cc0581c77a7f"

--000000000000fad4cc0581c77a7f
Content-Type: text/plain; charset="UTF-8"

test abc

--000000000000fad4cc0581c77a7f
Content-Type: text/html; charset="UTF-8"

<div dir="ltr"><div dir="ltr"><span style="color:rgb(46,139,87);font-family:Monaco,"Andale Mono","Courier New",Courier,mono;font-size:10.8px">test abc</span><br></div></div>

--000000000000fad4cc0581c77a7f--

GMAIL IMAP:
Content-Type: multipart/alternative; boundary="0000000000005c67120581c77a4c"

--0000000000005c67120581c77a4c
Content-Type: text/plain; charset="UTF-8"

test abc

--0000000000005c67120581c77a4c
Content-Type: text/html; charset="UTF-8"

<div dir="ltr"><div dir="ltr"><span style="color:rgb(46,139,87);font-family:Monaco,"Andale Mono","Courier New",Courier,mono;font-size:10.8px">test abc</span><br></div></div>

--0000000000005c67120581c77a4c--)

GMAIL webmail:
Content-Type: multipart/alternative; boundary="0000000000005c67120581c77a4c"

--0000000000005c67120581c77a4c
Content-Type: text/plain; charset="UTF-8"

test abc

--0000000000005c67120581c77a4c
Content-Type: text/html; charset="UTF-8"

<div dir="ltr"><div dir="ltr"><span style="color:rgb(46,139,87);font-family:Monaco,"Andale Mono","Courier New",Courier,mono;font-size:10.8px">test abc</span><br></div></div>

--0000000000005c67120581c77a4c--

(Reporter)

Comment 1

2 months ago

The 60.5.1 preview (meant to fix the chunk problem) from https://support.mozilla.org/en-US/questions/1249414 appears to have fixed the problem on my PC. Too early to tell if it helps the other users.

Comment 2

2 months ago

Thanks for info. I've been working on this several days to determine why my one line changed broke tb with no luck. Can you send me an email with the problem. Maybe that will help. (I haven't read the details of your comment 0 post yet.)

And yes, I'm pretty sure the 60.5.1 changes will fix this for everyone since it returns chunk handling to 60.4 state.

Comment 3

2 months ago

Ok, I sent a "test abc" message from gmail webmail. I see the problem in gmail account Sent Mail on tb. On another account that I cc'd to, it looks OK in tb. At least now I see the/a problem that I can debug. Thanks!

Comment 4

2 months ago

I now see why the chunking change in 60.5 causes the problem and is fixed by the revert in 60.5.1.
So this is a duplicate of bug 1494764.

Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1494764
You need to log in before you can comment on or make changes to this bug.