Closed Bug 1528021 Opened 4 years ago Closed 4 years ago

Firefox uses deprecated gtk-menu-popup causing issues in Wayland

Categories

(Core :: Widget: Gtk, defect)

67 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1423598

People

(Reporter: jhnmlkvch9, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image ffmenu.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

  1. In a wayland compositor (weston for example) open Firefox nightly with GDK_BACKEND=wayland
  2. Right click on the right edge of the firefox window

Actual results:

The context menu is rendered partly outside the firefox window.

Expected results:

The context menu should've been re-positioned to appear fully within the firefox window.

This is caused by firefox using the deprecated gtk-menu-popup. This should be updated for Wayland backends. In addition to popups being rendered off-screen, they are also mispositioned away from the point of the right-click. Here are a couple of relevant links:

https://developer.gnome.org/gtk3/stable/GtkMenu.html#gtk-menu-popup
https://bugzilla.gnome.org/show_bug.cgi?id=772096#c10

This affects the behavior of firefox wayland on Sway WM for example:

https://github.com/swaywm/sway/issues/3135

Blocks: wayland
Component: Untriaged → Widget: Gtk
Product: Firefox → Core

This looks like a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1339920 and/or https://bugzilla.mozilla.org/show_bug.cgi?id=1423598.

The issue is also present on other wayland compositors such as GNOME.

It's a dupe of Bug 1423598.

Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.