Tab should indicate that a <video> inside of it is being viewed in Picture-in-Picture, and perhaps not display the audio indicator

VERIFIED FIXED in Firefox 69

Status

()

defect
P1
normal
VERIFIED FIXED
5 months ago
22 days ago

People

(Reporter: yoasif, Assigned: JSON_voorhees)

Tracking

(Blocks 1 bug, {nightly-community})

Trunk
mozilla69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 unaffected, firefox68 unaffected, firefox69 verified)

Details

Attachments

(2 attachments)

On Ubuntu Disco.

STR:

  1. enable media.videocontrols.picture-in-picture.enabled
  2. Visit https://www.youtube.com/watch?v=3WQHDUYk310
  3. Right click twice on video, choose Picture in Picture

What happens:

Video pops out, but audio can't be heard.

Expected result:

Audio should continue playing.

Blocks: videopip
Duplicate of this bug: 1528564
Priority: -- → P1

This should be fixed by bug 1521964.

Depends on: 1521964
Duplicate of this bug: 1532026
Blocks: 1521954
No longer blocks: videopip

Hi Asif Youssuff, can you confirm that this is no longer an issue with bug 1521964 fixed?

Flags: needinfo?(yoasif)

Mike, I now hear audio, but the pop-out acts differently than I expect -- now, the audio seems to be coming from the tab that the video is popped out from - the mute button appears in the tab, and I can't pause the video based on focusing the pop-out.

Is that expected? It feels weird that the video is popped out but the audio is coming from the tab - feels more like ventriloquism than PIP.

Flags: needinfo?(yoasif)

(In reply to Asif Youssuff from comment #5)

Mike, I now hear audio, but the pop-out acts differently than I expect -- now, the audio seems to be coming from the tab that the video is popped out from - the mute button appears in the tab, and I can't pause the video based on focusing the pop-out.

Controlling the playback within the popped out video is something that still needs to be finished.

Is that expected? It feels weird that the video is popped out but the audio is coming from the tab - feels more like ventriloquism than PIP.

Can you describe what you mean by "the audio is coming from the tab"? Is this because the audio is controlled from the originating tab? FWIW, this is how Picture in Picture works in Opera, Safari and Chrome.

Flags: needinfo?(yoasif)

Can you describe what you mean by "the audio is coming from the tab"? Is this because the audio is controlled from the originating tab? FWIW, this is how Picture in Picture works in Opera, Safari and Chrome.

I guess I should play with the other browsers in this case. ;)

But yeah, that is the gist of the issue -- perhaps duplication of video is expected, but I guess I expected that the tab would no longer be playing sound and the popped out video would be playing the sound. In Chromium, at least, it seems like the video is not duplicated in the initial tab, but instead says "This video is playing in picture in picture mode" and the speaker indicator is not shown in the tab. Using the player's volume controls in Chromium seems to work, but the audio seems to be coming from the popped out video.

Flags: needinfo?(yoasif)

(In reply to Asif Youssuff from comment #7)

but instead says "This video is playing in picture in picture mode" and the speaker indicator is not shown in the tab. Using the player's volume controls in Chromium seems to work, but the audio seems to be coming from the popped out video.

Right - this is bug 1531101. Let's wait for that one to be fixed, and we'll revisit this one to make sure it's behaving as you expect.

Depends on: 1531101

Hi Asif,

Now that bug 1531101, and is available in Nightly, does it match your expectations, audio-wise? Or am I still misunderstanding the bug?

Flags: needinfo?(yoasif)
Posted image chrome-pip.png

Mike,

Just tested the newest build. bug 1531101 definitely improves things, but I think that the way Chromium does it is still better than Firefox, since it stops showing the speaker icon when in PIP mode, and instead shows a PIP icon (attached). When the video is popped back into to the page, Chromium then shows the speaker icon again.

As mentioned previously, the speaker icon makes it seem like the audio is coming from the parent window - there is a visual disconnect that feels like ventriloquism, so it doesn't feel like the audio is coming from the popped out window.

Updating the icon would clear up that disconnect, imo.

Flags: needinfo?(yoasif)

Ah, I think I understand. Okay, thank you.

I'll see if I can get UX's take on this on how we should proceed.

Summary: Picture in Picture mode doesn't output audio → Tab should indicate that a <video> inside of it is being viewed in Picture-in-Picture.
Summary: Tab should indicate that a <video> inside of it is being viewed in Picture-in-Picture. → Tab should indicate that a <video> inside of it is being viewed in Picture-in-Picture, and perhaps not display the audio
Summary: Tab should indicate that a <video> inside of it is being viewed in Picture-in-Picture, and perhaps not display the audio → Tab should indicate that a <video> inside of it is being viewed in Picture-in-Picture, and perhaps not display the audio indicator
Assignee: nobody → djustice
Blocks: 1527926
No longer blocks: 1521954
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1c62e73258b4
Show PiP Icon in parent tab of media. r=mconley
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

It looks like .tab-icon-sound and .tab-icon-pip are mutually exclusive, and this could have been implemented as another variation of .tab-icon-sound? Why did you choose to add a separate element instead?

Flags: needinfo?(djustice)
Regressions: 1554579
Keywords: regression

Why did you choose to add a separate element instead?

Initially we hadn't decided if we were going to show the .tab-icon-sound beside the .tab-icon-pip element.

this could have been implemented as another variation of .tab-icon-sound

True, happy to fix this up.

Flags: needinfo?(djustice)

Build ID 20190626093633
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Verified as fixed on the latest Nightly build on Windows 10.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.