Closed Bug 1528493 Opened 1 year ago Closed 1 year ago

Add Maybe value support to IPDL

Categories

(Core :: IPC, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla67
Fission Milestone M1
Tracking Status
firefox67 --- fixed

People

(Reporter: Nika, Assigned: Nika)

References

Details

Attachments

(2 files)

This adds the syntax T? to define an optional value, and migrates the OptionalIPCStream consumer to use it.

Priority: -- → P1
Priority: P1 → P2
Duplicate of this bug: 1529553
Blocks: 1519151
Fission Milestone: --- → M1
Whiteboard: [2/22] patches r+, ready to land
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/55d65fdac5ec
Part 1: Add support for maybe types to IPDL, r=mccr8,froydnj
https://hg.mozilla.org/integration/autoland/rev/0dacb4dc82e5
Part 2: Move OptionalIPCStream to use new maybe types, r=baku
Whiteboard: [2/22] patches r+, ready to land → [2/22] patches pushed
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Whiteboard: [2/22] patches pushed
You need to log in before you can comment on or make changes to this bug.