Closed Bug 1528876 Opened 4 years ago Closed 4 years ago

enable AudioWorklet in Nightly Web Audio wpt

Categories

(Core :: Web Audio, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: karlt, Assigned: karlt)

References

Details

Attachments

(1 file)

See Also: → 1481676
Pushed by ktomlinson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6fdef2d548e7
enable AudioWorklet in Nightly Web Audio wpt r=padenot
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

#3 Is AudioWorklet disabled in Nightly except for wpt tests?

Yes. For now, we have just enough things working to run a few test to make sure we're on the right track. More is coming soon, for example in bug 1558123.

#5 Did you delete the comment #6 as "off-topic"? Am trying to confirm a bug that apparently appears in both Chromium and Nightly. Just happened to narrow the cause down to use of requestFrame() in code that uses AudioWorklet and was attempting to confirm the cause by running the same code at Nightly. In any event https://github.com/web-platform-tests/wpt/issues/17558

If you see a bug, please open a bug with a test case. What you're describing has nothing to do with AudioWorklet.

#8 Perhaps you did not gather what was asking at #6? Was asking if it would be possible to test the same code that ran at Chromium at Nightly. Prior to using the AudioWorklet (to use process() in place of requestAnimationFrame() by posting message to main thread to execute requestFrame()) code at Chromium had not previously observed the audio being muted for the last 1 second at Chromium, though which had previously observed at Nightly. After running the code over and over with and without captureStream(0) and requestFrame() found the common denominator which lead to last 1 second or less being muted was requestFrame(). The simplest test solution would be to run the exact same code at both Chromium and Firefox (save for the requestFrame() being defined differently at the browsers) to confirm the cause of the muting of audio was in fact <canvas>. Since testing of AudioWorklet is being enabled for wpt it is sensible to ask if users in the wild can also test AudioWorklet at Nightly, due to the fact that actual human tests can and do find edge cases that automated tests generally cannot and do not find. Am currently composing a version using requestAnimationFrame() .

#8 This is the original code https://plnkr.co/edit/NoVi5Q?p=preview. Still working on composing comparable code without using AudioWorklet

You need to log in before you can comment on or make changes to this bug.