mid-air collision while marking a dup duplicates "this bug has been marked..."

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Creating/Changing Bugs
--
minor
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: Jesse Ruderman, Assigned: Frédéric Buclin)

Tracking

unspecified
Bugzilla 3.0
Dependency tree / graph
Bug Flags:
blocking2.20 -
blocking2.18 -

Details

(Whiteboard: [blocker will fix], URL)

(Reporter)

Description

16 years ago
Steps:
1. Load a bug.
2. Someone else adds a comment.
3. Try to mark the bug as a dup (in my case, without adding a comment).
4. Click through the "mid-air collision" page.

Result: the "this bug has been marked as a duplicate of" line is duplicated
(example: http://bugzilla.mozilla.org/show_bug.cgi?id=152860#c2)
Is this a regression? We're doing midair checks after setting FORM{'COMMENT'},
which then goes through to the hidden data

Comment 2

16 years ago
*** Bug 153711 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
It also happened to me with bug 178150...
(Assignee)

Comment 4

14 years ago
*** Bug 276216 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking2.20?
Flags: blocking2.18?

Comment 5

14 years ago
*** Bug 276216 has been marked as a duplicate of this bug. ***
This bug has been around pretty much forever, and although it's annoying, it's
only a cosmetic issue.  If someone patches it, I'll take it for 2.18, but I
won't block release on it.
Flags: blocking2.20?
Flags: blocking2.20-
Flags: blocking2.18?
Flags: blocking2.18-
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.18
(Assignee)

Updated

13 years ago
Depends on: 225221
(Assignee)

Comment 7

13 years ago
Will be trivial to fix as soon as bug 225221 gets fixed. I already know how to
do this.

Note to self: append "this bug has been marked..." to the initial comment only
when adding the corresponding comment to the original bug, that is: in the 'if
($duplicate)' block around line 1840 in process_bug.cgi instead of line 1055.
Assignee: myk → LpSolit
Target Milestone: Bugzilla 2.18 → Bugzilla 2.22
(Assignee)

Comment 8

13 years ago
I won't have time to play with it before the 2.22 freeze
Target Milestone: Bugzilla 2.22 → ---

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED
Depends on: 353656
Whiteboard: [blocker will fix]
Target Milestone: --- → Bugzilla 3.0
(Assignee)

Comment 9

12 years ago
Fixed by bug 353656
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.