Closed Bug 1529035 Opened 6 months ago Closed 5 months ago

Discovery Stream layout delay causing cache to be used

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 68
Iteration:
68.2 - Apr 1 - 14
Tracking Status
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- fixed

People

(Reporter: thecount, Assigned: thecount)

References

Details

(Keywords: github-merged)

Attachments

(1 file)

If the layout returns with a delay and the client has a layout cache, the client uses the cache, then when the delayed layout returns, it updates any open tabs.

We should probably not use the cache if the pref has changed and we're waiting for a response to succeed/fail. If it fails, we can then use cache.

Need info on myself to add steps to test.

Flags: needinfo?(sdowne)
Iteration: --- → 67.3 - Feb 25 - Mar 10
Priority: -- → P2
Priority: P2 → P1

To test:

  1. Setup two tabs from the same profile side by side.
  2. Tab 1 can be about:config
  3. Tab 2 can be about:home
  4. From tab 1, set the pref browser.newtabpage.activity-stream.discoverystream.config to {"api_key_pref":"extensions.pocket.oAuthConsumerKey","enabled":true,"show_spocs":true,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=$apiKey&layout_variant=basic"}
  5. Tab 2 should render basic.
  6. Update pref from step 4 to {"api_key_pref":"extensions.pocket.oAuthConsumerKey","enabled":true,"show_spocs":true,"layout_endpoint":"https://gist.githubusercontent.com/ScottDowne/fedc94f5ea33b320083fc302987a3be2/raw/06492b8d7caab27c3cd6c0c3e10b93f38240ff11/gistfile1.txt"}

expected, it should load cleanly, with no jank. If you see jank it'll be seeing top sites first before the rest is ready something's not working.

Flags: needinfo?(sdowne)
Iteration: 67.3 - Feb 25 - Mar 10 → 68.1 - Mar 18 - 31
Assignee: nobody → sdowne
No longer blocks: 1512725
Iteration: 68.1 - Mar 18 - 31 → 68.2 - Apr 1 - 14

For some reason this wasn't linked, closing as fixed.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1529307
Blocks: 1541502
Keywords: github-merged
Target Milestone: --- → Firefox 68
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.