Closed Bug 1529141 Opened 8 months ago Closed 6 months ago

Firefox Preferences "Home" section has unnecessarily wide content (triggering truncation & horizontal scrollbar), due to long unbroken sentence about "Content Discovery in Firefox Home"

Categories

(Firefox :: Preferences, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- fixed

People

(Reporter: dholbert, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:

  1. Make your Firefox window ~1024 pixels wide. (This is a little over half the width of my 24" Dell Monitor width).

  2. Visit about:preferences#home

ACTUAL RESULTS:
The content doesn't fit -- we trigger a horizontal scrollbar.

EXPECTED RESULTS:
Content should be less wasteful of space / more responsive to window size. At some threshold a scrollbar will probably be needed, but 1024px feels quite wide to be already below that threshold.

Every other preferences pane and every "about:addons" section fits nicely in this window-size. It's only this #home section of Preferences that is too wide.

The large content-width here seems to entirely be caused by a <description> tag with this content, which we don't linebreak for some reason:

Content Discovery in Firefox Home allows you to discover high-quality, relevant articles from across the web.

If I delete that element in devtools, then the whole layout adjusts and fits my window size nicely.

So it seems that the solution here is to allow that long sentence to be linebroken, either by adding a max-width or doing something else to make it responsive to the window-size.

searchfox blame indicates that this string was added in Bug 1520324.
https://hg.mozilla.org/mozilla-central/rev/8de26a67ac5c#l21.14

Marking as a regression from that bug & CC'ing the folks involved.

Blocks: 1520324
Keywords: regression
Summary: Firefox Preferences "Home" section has unnecessarily wide content (triggering horizontal scrollbar) → Firefox Preferences "Home" section has unnecessarily wide content (triggering horizontal scrollbar), due to long unbroken sentence about "Content Discovery in Firefox Home"
Summary: Firefox Preferences "Home" section has unnecessarily wide content (triggering horizontal scrollbar), due to long unbroken sentence about "Content Discovery in Firefox Home" → Firefox Preferences "Home" section has unnecessarily wide content (triggering truncation & horizontal scrollbar), due to long unbroken sentence about "Content Discovery in Firefox Home"
Blocks: 1512725
No longer blocks: 1512725

This issue should be resolved with fix of bug 1533601 in 68

Fixed in https://hg.mozilla.org/mozilla-central/rev/7a435211fa07

This should only have affected nightly users and those in the experiments.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
QA Whiteboard: [qa-68b-p2]
You need to log in before you can comment on or make changes to this bug.