clang-format extension erroring on Windows

RESOLVED FIXED in Firefox 67

Status

defect
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: JSON_voorhees, Assigned: andi)

Tracking

({regression})

unspecified
mozilla67
Desktop
Windows 10
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67 fixed)

Details

Attachments

(1 attachment)

Errors when running hg commit with clang-format extension enabled on Windows 10

Dave Justice@LAPTOP-NA0Q0G86 /c/mozilla-build/mozilla-central
$ hg commit
Processing 5 file(s)...
Process PoolWorker-1:
Traceback (most recent call last):
  File "c:\mozilla-build\python\lib\multiprocessing\process.py", line 267, in _bootstrap
    self.run()
  File "c:\mozilla-build\python\lib\multiprocessing\process.py", line 114, in run
    self._target(*self._args, **self._kwargs)
  File "c:\mozilla-build\python\lib\multiprocessing\pool.py", line 102, in worker
Process PoolWorker-2:
Traceback (most recent call last):
   File "c:\mozilla-build\python\lib\multiprocessing\process.py", line 267, in _bootstrap
   task = get()
  File "c:\mozilla-build\python\lib\multiprocessing\queues.py", line 376, in get
     self.run()
   return recv()
  File "c:\mozilla-build\python\lib\multiprocessing\process.py", line 114, in run
I    self._target(*self._args, **self._kwargs)
mportError: No module named 4b8aac71360011e98d4600e18ca3ea22
P rocess PoolWorker-3:
 File "c:\mozilla-build\python\lib\multiprocessing\pool.py", line 102, in worker
Traceback (most recent call last):
     task = get()
 File "c:\mozilla-build\python\lib\multiprocessing\process.py", line 267, in _bootstrap
  File "c:\mozilla-build\python\lib\multiprocessing\queues.py", line 376, in get
    self.run()
  File "c:\mozilla-build\python\lib\multiprocessing\process.py", line 114, in run
    self._target(*self._args, **self._kwargs)
  File "c:\mozilla-build\python\lib\multiprocessing\pool.py", line 102, in worker
    return recv()
 I   task = get()
mportError: No module named 4b8aac71360011e98d4600e18ca3ea22
  File "c:\mozilla-build\python\lib\multiprocessing\queues.py", line 376, in get
    return recv()
ImportError: No module named 4b8aac71360011e98d4600e18ca3ea22

A little more context for this:

I had gotten my repo up to date with latest from upstream and had about 3 local commits that I used hg strip to get rid of before committing my changes which triggered this error.

Andi will have a look as I don't know much about windows

Assignee: nobody → bpostelnicu
Blocks: 1525725

Bug 1529415 looks related, maybe a duplicate/unrelated to the clang-format hg extension itself.

See Also: → 1529415
Assignee

Comment 4

4 months ago

This is a regression caused by this patch.

Assignee

Updated

4 months ago
Duplicate of this bug: 1529415

Andi, if this is too complex, we could just disable parallel execution on windows until we have a fix.

Assignee

Comment 7

4 months ago
  1. A sheriff is going to revert b59977d42a4d
  2. I will redo this after we have the backout using futures since multiprocessing is broken on windows.

Aryx, Dluca, can you please backout changeset b59977d42a4d?

Flags: needinfo?(dluca)
Flags: needinfo?(aryx.bugmail)
Flags: needinfo?(dluca)
Flags: needinfo?(aryx.bugmail)
Assignee

Comment 9

4 months ago

Parts of this patch were taken from the original work of :bbouvier in Bug 1521772.
We needed to revert Bug 1521772 since it broken Windows compatibility.

Comment 10

4 months ago
bugherder
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.