windows/aarch64 - netwerk/test/unit/test_esni_dns_fetch.js | xpcshell return code: 0

RESOLVED FIXED

Status

()

defect
P3
normal
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-triaged])

#[markdown(off)]
Filed by: egao [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=230585134&repo=try

https://queue.taskcluster.net/v1/task/eA-BeOxqROeRw162f_ui2Q/runs/0/artifacts/public/logs/live_backing.log

Observed on windows10-aarch64, xpcshelltest chunk 5.

18:04:13 INFO - TEST-START | netwerk/test/unit/test_esni_dns_fetch.js
18:04:15 WARNING - TEST-UNEXPECTED-FAIL | netwerk/test/unit/test_esni_dns_fetch.js | xpcshell return code: 0
18:04:15 INFO - TEST-INFO took 1832ms
18:04:15 INFO - >>>>>>>
18:04:15 INFO - PID 7576 | Unable to load \\untrusted-startup-test-dll.dll; LoadLibraryW failed: 126
18:04:15 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
18:04:15 INFO - TEST-PASS | netwerk/test/unit/test_esni_dns_fetch.js | run_test - [run_test : 16] "49863" != null
18:04:15 INFO - TEST-PASS | netwerk/test/unit/test_esni_dns_fetch.js | run_test - [run_test : 17] "49863" != ""
18:04:15 INFO - (xpcshell/head.js) | test pending (2)
18:04:15 INFO - PID 7576 | starting test 0
18:04:15 INFO - (xpcshell/head.js) | test pending (3)
18:04:15 INFO - (xpcshell/head.js) | test MAIN run_test finished (3)
18:04:15 INFO - running event loop
18:04:15 WARNING - TEST-UNEXPECTED-FAIL | netwerk/test/unit/test_esni_dns_fetch.js | onLookupByTypeComplete - [onLookupByTypeComplete : 88] false == true
18:04:15 INFO - C:/tasks/task_1551186399/build/tests/xpcshell/tests/netwerk/test/unit/test_esni_dns_fetch.js:onLookupByTypeComplete:88
18:04:15 INFO - C:\tasks\task_1551186399\build\tests\xpcshell\head.js:_do_main:224
18:04:15 INFO - C:\tasks\task_1551186399\build\tests\xpcshell\head.js:_execute_test:526
18:04:15 INFO - -e:null:1
18:04:15 INFO - exiting test
18:04:15 INFO - PID 7576 | JavaScript error: C:\\tasks\\task_1551186399\\build\\tests\\xpcshell\\head.js, line 739: NS_ERROR_ABORT:
18:04:15 INFO - "CONSOLE_MESSAGE: (error) [JavaScript Error: "NS_ERROR_ABORT: " {file: "C:\\tasks\\task_1551186399\\build\\tests\\xpcshell\\head.js" line: 739}]"
18:04:15 INFO - <<<<<<<

Keywords: regression
Summary: win10/aarch64 - netwerk/test/unit/test_esni_dns_fetch.js | xpcshell return code: 0 → windows/aarch64 - netwerk/test/unit/test_esni_dns_fetch.js | xpcshell return code: 0
Priority: P5 → P3
Whiteboard: [necko-triaged]

With the latest try run of xpcshell-5 on windows10-aarch64, it looks like this test is now passing as expected.

I am closing this bug as resolved.

Try: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=33a2fa7bf0d27184a606318f80ec00d5ef2387d8&selectedJob=231977046

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Depends on: 1536211

Test is disabled with patch https://phabricator.services.mozilla.com/D23922 for windows10-aarch64 due to consistent failure.

OS: Unspecified → Windows
Hardware: Unspecified → ARM64
Depends on: 1547412

Test is re-enabled with bug #1547412 and so this bug can be closed.

Status: REOPENED → RESOLVED
Closed: 4 months ago3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.