Closed Bug 1530815 Opened 8 months ago Closed 8 months ago

Crash in [@ r_assoc_fetch_bucket]

Categories

(Core :: WebRTC: Networking, defect, P1, critical)

Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- fixed

People

(Reporter: calixte, Assigned: bwc)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-30866bb4-e544-4eb6-940a-b22070190226.

Top 10 frames of crashing thread:

0 libxul.so r_assoc_fetch_bucket media/mtransport/third_party/nrappkit/src/util/libekr/r_assoc.c:250
1 libxul.so nr_reg_fetch_node media/mtransport/third_party/nrappkit/src/util/libekr/r_assoc.c:271
2 libxul.so nr_reg_set media/mtransport/third_party/nrappkit/src/registry/registry_local.c:617
3 libxul.so nr_reg_local_set_uchar media/mtransport/third_party/nrappkit/src/registry/registry_local.c:986
4 libxul.so mozilla::NrIceCtx::InitializeGlobals media/mtransport/nricectx.cpp:454
5 libxul.so mozilla::NrIceCtx::Create media/mtransport/nricectx.cpp:286
6 libxul.so mozilla::MediaTransportHandlerSTS::CreateIceCtx media/webrtc/signaling/src/peerconnection/MediaTransportHandler.cpp:339
7 libxul.so mozilla::PeerConnectionImpl::Initialize media/webrtc/signaling/src/peerconnection/PeerConnectionImpl.cpp:473
8 libxul.so mozilla::PeerConnectionImpl::Initialize media/webrtc/signaling/src/peerconnection/PeerConnectionImpl.cpp:545
9 libxul.so mozilla::dom::PeerConnectionImpl_Binding::initialize dom/bindings/PeerConnectionImplBinding.cpp:97

There are 3 crashes (from 3 installations) in nightly 67 with buildid 20190226093755. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1521879.

[1] https://hg.mozilla.org/mozilla-central/rev?node=f18e61be455d

Flags: needinfo?(docfaraday)

This is extremely odd; it seems that the nr_registry stuff is failing to init for some reason, but I cannot see a reason why that might be...

Looking into it.

Maybe we should be initting NSS before we try to init the nr_registry stuff?

I have an idea of what might be happening. Patch coming up.

Assignee: nobody → docfaraday
Rank: 10
Flags: needinfo?(docfaraday)
Priority: -- → P1
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ee6e4e37189
Call RLogConnector::CreateInstance on main, not STS, because that's where we init the nr_registry stuff normally. r=mjf
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Duplicate of this bug: 1531031
Crash Signature: [@ r_assoc_fetch_bucket] → [@ r_assoc_fetch_bucket] [@ nr_reg_raise_event]
You need to log in before you can comment on or make changes to this bug.