Closed Bug 1530948 Opened 1 year ago Closed 1 year ago

sessionrestore linux64 regression on push 367ca1e168537c05f091c766e11b2c8338621cba

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Tracking Status
firefox67 --- fixed

People

(Reporter: bzbarsky, Unassigned)

References

(Blocks 1 open bug)

Details

See bug 1528762 comment 12.

Alert link: https://treeherder.mozilla.org/perf.html#/alerts?id=19419

For my reference, this is part of the "o" (talos-other) job, looks like.

I'll do some try pushes in the morning to see what's going on here, I guess.

Just to be clear, this is only an issue observable with linux64 pgo builds? I spot-checked linux64 with no pgo and windows pgo, and neither of those seems to show any regression there (in fact, windows PGO seems to show an improvement in the same range).

Flags: needinfo?(igoldan)

And just to make sure we're on the same page, I am looking at https://treeherder.mozilla.org/perf.html#/graphs?timerange=1209600&series=autoland,1647935,1&series=mozilla-inbound,673a20535a837f66c2114b0aed215e5542c6ec05,0 which shows:

  1. A rise around Feb 15.
  2. Some more rise through Feb 22.
  3. Maybe a drop on Feb 22.
  4. No more rise after that point.

Is that about right?

(In reply to Boris Zbarsky [:bzbarsky, bz on IRC] from comment #2)

Just to be clear, this is only an issue observable with linux64 pgo builds? I spot-checked linux64 with no pgo and windows pgo, and neither of those seems to show any regression there (in fact, windows PGO seems to show an improvement in the same range).

Yes, that's right. It's Linux 64bit PGO-specific.

Flags: needinfo?(igoldan)

(In reply to Boris Zbarsky [:bzbarsky, bz on IRC] from comment #3)

And just to make sure we're on the same page, I am looking at https://treeherder.mozilla.org/perf.html#/graphs?timerange=1209600&series=autoland,1647935,1&series=mozilla-inbound,673a20535a837f66c2114b0aed215e5542c6ec05,0 which shows:

  1. A rise around Feb 15.
  2. Some more rise through Feb 22.
  3. Maybe a drop on Feb 22.
  4. No more rise after that point.

Is that about right?

Yes, you are right. I didn't spot the increase from Feb 22. Let me check that.

OK, so I did several try pushes:

  1. The changeset right before bug 1528146 relanded: https://treeherder.mozilla.org/#/jobs?repo=try&revision=19352ff3a667095a54df1fd402df578ede7675f4

  2. (1) plus the fix for bug 1528146: https://treeherder.mozilla.org/#/jobs?repo=try&revision=0d5cc0bd77b28139b1b7036bfeeb12e42cec9716

  3. (2) plus the fix for bug 1528762: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ce6768982cfd81d5de29c662484a3c483d28b8a3

The perfherder compares from (1) to (2) and from (1) to (3) are https://treeherder.mozilla.org/perf.html#/compare?originalProject=try&originalRevision=19352ff3a667095a54df1fd402df578ede7675f4&newProject=try&newRevision=0d5cc0bd77b28139b1b7036bfeeb12e42cec9716&framework=1 and https://treeherder.mozilla.org/perf.html#/compare?originalProject=try&originalRevision=19352ff3a667095a54df1fd402df578ede7675f4&newProject=try&newRevision=0d5cc0bd77b28139b1b7036bfeeb12e42cec9716&framework=1 respectively.

For the sessionrestore test it looks like the baseline is at about 331, which is the "regressed" number from the alert. Bug 1528146 increases it to about 336. Bug 1528762 then decreases it to about 331.

So my best guess at what's going on is:

  • Bug 1528146 did regress this test a bit.
  • Bug 1528762 addressed that regression.
  • There were possibly other, independent regressions at about the same time.

Thoughts?

Flags: needinfo?(igoldan)

(In reply to Boris Zbarsky [:bzbarsky, bz on IRC] from comment #6)

So my best guess at what's going on is:

  • Bug 1528146 did regress this test a bit.
  • Bug 1528762 addressed that regression.
  • There were possibly other, independent regressions at about the same time.

Thoughts?

You are correct. Bug 1528762 entirely fixed this regression, so we can close this as FIXED.
Indeed, there has been an independent regression which happened around February 20, caused by bug 1527066. I will file a separate bug for that.

Boris, thanks a lot for checking this with me.

Flags: needinfo?(igoldan)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Depends on: 1528762

Ionuț, thank you for digging into the data and figuring out what's going on!

Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.