display labels as a combo box in the current message

RESOLVED EXPIRED

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED EXPIRED
16 years ago
8 years ago

People

(Reporter: Alec Flett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I was just thinking that it would be one less step if you could display the
label for the current message in the message header area, and then allow it to
be changed with a drop-down/combo box thing. it would be one less step than
going through the Message menu or the context menu, and would further expose
this feature.

If you could do some sort of ui where the label looks like static text (with
color!) but becomes a combo box when you click on it, that would be especially
cool - less clutter added to the header area.

Comment 1

16 years ago
We do have keyboard shortcuts, you know -- 0 (no label/none) 1-5 for the 5 label
values.

We also initially meant to have the label column be able to cycle through the
labels on click -- see bug 113851.  I think this is essentially a duplicate of that.

*** This bug has been marked as a duplicate of 113851 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: olgam → laurel
(Reporter)

Comment 2

16 years ago
yeah, I had forgotten about the shortcut keys.. but I guess half the reason I
filed this was for discoverability, the shortcut keys don't solve that :)

I think I'm going to reopen, because while I think the other bug is a great
idea, I also think this would be nice.. (I mean, if this gets resolved WONTFIX
or whatever, that's fine, but for the record I think its a different request) -
I think both bugs could be fixed - the other one doesn't make the feature any
more visible, though it certainly makes it easier to use.


Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

16 years ago
Sort of related/dup of Bug 150560.
(Reporter)

Comment 4

16 years ago
ah yes - that feature and more :)

Comment 5

16 years ago
One reservation I have about this idea based on recent history: 
adding another display to the header area may be well and good, but we already
have plently of display things in the header area and have some issues with
refreshing header display in many scenarios.  Some things which come to mind are
problems with long headers (like subject), expanding and collapsing adressee
lines, switching view headers mode or collapsing/expanding header area,
attachment lists, etc.  Adding another component (particularly a
widget/dropdown) in the envelope would need to be well thought out so as not to
clutter the area and also work well when refresing/navigating. 
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Status: REOPENED → NEW
Assignee: mail → nobody
Severity: normal → enhancement
QA Contact: laurel → message-display
Summary: RFE: display labels as a combo box in the current message → display labels as a combo box in the current message

Comment 6

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 7

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago8 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.