glitch with scrolling & incremental painting

VERIFIED DUPLICATE of bug 41386

Status

Core Graveyard
GFX
P3
normal
VERIFIED DUPLICATE of bug 41386
18 years ago
9 years ago

People

(Reporter: kipp, Assigned: Kevin McCluskey (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Not sure I know who to assign this to, but I'm starting with the compositor.

(you will need to install the resources it uses in res/leaky if you are not and
linux and have leaky enabled; see the Makefile.in in tools/mozilla/leaky for
what resources you will need)

The glitch is this: if you use the viewer to look at the test case and open up
several of the elements in the tree until you get a scroll bar, then scroll the
window slightly, then click to close things back up so that you no longer need a
scrollbar THEN you will end up with an invalid display...Anything that triggers
a repaint fixes it...
(Reporter)

Comment 1

18 years ago
Created attachment 1943 [details]
my test case

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 2

18 years ago
Reassigning all compositor bugs to kevin.
Assignee: beard → kmcclusk
Status: ASSIGNED → NEW

Comment 3

18 years ago
Created attachment 6885 [details]
Demonstration of scroll/redraw bug, Milestone 14, 24/03/2000

Comment 4

18 years ago
The demonstration GIF dated 03/24/00 06:35 shows how the scrolling redraw bug 
interacts with the AllAdvantage viewbar under NT4 SP4, implying the problem 
might be connected with different physical/logical screen heights confusing the 
off-screen buffering algorithm (?) - Peet
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 41386 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.