horizontal scrolling of page with sidebar open cuts page with sidebar closed

VERIFIED FIXED in Future

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Ralph Loader, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
(1) Go to a page with a reasonably wide image.

(2) Resize browser and sidebar so that horizontal scrollbars appear when the
side bar is displayed, but not when the side bar is not displayed.

(3) Display the side bar, and scroll the browser window to make the right hand
edge of the page visible.

(3) Undisplay the side bar (by clicking on the light blue button in the middle
of its border.

The result is that the horizontal scrollbar disappears, but the page is shifted
left, so that not all of it can be seen in the browser.

Ralph.

Comment 1

18 years ago
I am using 2000060409 on Linux, and not having this problem at all. I'm going to
switch this to WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 2

18 years ago
reporter emailed me:
Battery841,

The problem is easily reproducible for me - just did so with 
2000060409.

I've put a sequence of 3 screen-shots up at
http://homepages.ihug.co.nz/~suckfish/mozilla

Could you take a look at them and see if they correspond to how you
tried to reproduce this?

For your reference, the URL the screen-shots are from is
http://ars.userfriendly.org/cartoons/?id=20000603&mode=classic.

My browser window is 966 pixels wide, and the toolbar (when opened)
about 180 pixels wide.

Ralph.

Comment 3

18 years ago
OK, I se this in Win32 build from today, 060508, under NT as well as same date
build for Mac.  Reopening, updating OS and Platform, resummarizing to horizontal
scrolling of page with sidebar open cuts page with sidebar closed, assigning to
Layout and default owner.
Status: RESOLVED → UNCONFIRMED
Component: Browser-General → Layout
OS: Linux → All
Hardware: PC → All
Resolution: WORKSFORME → ---
Summary: Horizontal scrolling wierdness → horizontal scrolling of page with sidebar open cuts page with sidebar closed

Comment 4

18 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 5

18 years ago
confirming based on asa's comments, reassigning
Assignee: asa → clayton
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: doronr → petersen

Comment 6

18 years ago
Reassiging to Kevin for bug triage.
Assignee: clayton → kmcclusk
(Assignee)

Comment 7

18 years ago
I was able to reproduce this in the current build.  Scrolling the window
vertically after producing the cut off page fixes the display of the page.

This bug has been marked "future" because the original netscape engineer working
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way
-- please attach your concern to the bug for reconsideration.
  
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Assignee)

Comment 8

18 years ago
*** Bug 15319 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 42862 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

17 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

17 years ago
I can no longer reproduce this bug; it appears to be fixed.

Comment 11

17 years ago
Marking verified per last comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.