Closed Bug 1532260 Opened 6 months ago Closed 3 months ago

animations involving inherit of colours no longer work

Categories

(Core :: SVG, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1358955

People

(Reporter: longsonr, Unassigned)

References

Details

(Keywords: regression)

See http://hoffmann.bplaced.net/svgtest/fill11.svg A difference between the fill and the stroke of the large circle indicates an error. I.e. the large circle should always appear to be a single colour.

Also http://hoffmann.bplaced.net/svgtest/fill12.svg which has the same failure i.e. a difference between the fill and the stroke of the large circle.

This worked in Firefox 48, not sure when it failed but it's broken by Firefox 60.

There are also problems reported with currentColor but I'm not sure what they are. Maybe they have been fixed. See http://hoffmann.bplaced.net/svgtest/index.php?in=fillstroke#paint and scroll down to currentColor.

Can you see what's wrong with currentColor Brian? Is the currentColor issue (if there is one) related to the inherit issue of this bug?

Flags: needinfo?(bbirtles)

Regression window with layout.css.servo.enabled=true:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3b94664811ab471a34b4903a810e2f6e5773e190&tochange=06ec956f753346236bf89f2bead2066d22778fc2

Triggered by: 06ec956f7533 Gregory Szorc — Bug 1366048 - Build stylo on win32 and win64 in automation; r=froydnj

Blocks: stylo
Priority: -- → P3

For filling animations there is a known issue: bug 1358955

But this appears to affect running animations. I'm not sure what the issue is or when I'll get a chance to dig into it. Leaving needinfo for now in case I get a chance to look later this week.

Based on comment 2 and comment 3, I am removing the regressionwindow-wanted tag.

This is a duplicate of Bug 1358955, it actually affects all values that are animated as CSS property.

The inherit will become the computed value when this specified value is first encountered, and the information that it is an inherit will be lost.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358955

I don't think we need to do anything, since no browser behaves correctly in this case...

Clearing needinfo as per comment 7.

Flags: needinfo?(bbirtles)
You need to log in before you can comment on or make changes to this bug.