Closed Bug 1532618 Opened 4 years ago Closed 3 years ago

[Wayland] Dragging bookmark/tab away and then returning before dropping performs copy instead of move

Categories

(Core :: Widget: Gtk, defect, P3)

All
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1576268

People

(Reporter: callahad, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached video wayland-bookmarks.webm

(See attached video)

Steps to reproduce:

  1. Launch Firefox with Wayland
  2. Display the Bookmarks toolbar
  3. Drag and entry to a new position on the toolbar

Expected:

  • The item moves to the new location

Actual:

  • The item is duplicated at the new position

As seen in the screencast, this occasionally works as expected.

Potentially related to Bug 1466444?

Priority: -- → P3
Whiteboard: [gfx-noted]

This happens when dragging a bookmark/tab far enough away that the cursor icon changes to a "+" icon indicating it is in "copy" mode. When dragging it back it remains in "copy" mode instead of automatically switching back to "move" mode like with XWayland. Have to manually press and hold Shift while dragging for it to switch to "move" mode.

Component: Graphics → Widget: Gtk
Priority: P3 → --
Summary: [wayland] Drag and drop on the Bookmarks toolbar duplicates items → [Wayland] Dragging bookmark/tab away and then returning before dropping performs copy instead of move
Whiteboard: [gfx-noted]
Priority: -- → P3
Duplicate of this bug: 1562599

This was recently fixed in latest Nightly by Bug 1576268.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1576268
You need to log in before you can comment on or make changes to this bug.